Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Why is my iphone 4 unable to charge immediately after updating to iOS 6? I am using an apple brand cable, I tried it on my computer, and I tried it in multiple wall outlets, no change. The charge is now 0% and I cant do anything, but before I did I powered down and did a restart and it did nothing. Phone was working perfectly before hand and now I don't know what to do. This less than 24 hrs after updating FYI. I'm really mad!

share|improve this question
add comment

1 Answer 1

The phone will charge even when the OS is powered down. Why not plug in your device and power it off (or wait for the battery to die and plug it in) and see.

If it won't charge after an OS update, you can be sure that there is a hardware issue with the charging circuitry. It's possible for a phone to get stuck in a loop where the CPU can take more power than a charger can provide, so the power cycle (or inevitable loss of battery power) could be needed to clear things and let it take a charge.

share|improve this answer
add comment

protected by Community Mar 23 '13 at 12:30

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.