Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'm using oh-my-zsh and iTerm2. I've also enabled the zsh-vim-mode plugin from oh-my-zsh. One of the annoyances I've encountered is my right prompt (RPS1 & RPROMPT) doesn't seem to show up. I'd like it to indicate what vim mode I'm currently in.

I'm using the robbyrussel theme. It seems my $RPS1 variable is set. I'm wondering if there's a configuration option I'm missing.


I'm running 10.7.

Same issue in 10.8.

share|improve this question
    
What is in your $RPS1? –  Alex Bolotov Feb 24 '13 at 7:44
    
Could you please attach your .zshrc? –  Alex Bolotov Feb 24 '13 at 17:37
    

3 Answers 3

up vote 2 down vote accepted
+100

Try wrapping your RPROMPT in single quotes. I've seen double quotes cause issues for others with their prompts before.

I would also ditch the precmd > setprompt process for the moment and just set RPROMPT directly to simplify for testing. Start with something like

precmd() {
  ...
}
PROMPT=$'\n$(rb_prompt) in $(directory_name) $(git_dirty)$(need_push)\n› '
RPROMPT='%{$fg_bold[cyan]%}$(todo)%{$reset_color%}'

and refine from there.

share|improve this answer

After investigating - I found a few things that fixed this:

  1. I had some oh-my-zsh plugins that were setting RPS1 instead of RPROMPT - it seems that setting both caused neither to be shown.
  2. Setting RPROMPT in precmd also caused it to disappear.
share|improve this answer

Make sure that $RPS1 or $RPROMPT is not defined in one of your plugins. For example, the plugin vi-mode defines $RPS1 inside an if statement. To test, disable ALL plugins inside your .zshrc and see if that fixes things.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.