Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Looks like my issue has been around for a while (iOS 5.0.1 (iPhone 4s) unable to synchronize with Internet Calendar File (ics)) — has anyone come up with a fix yet? I am trying to sync my iPhone calendars with the calendar on my PC that is in .ics format. The .ics file is located on a home server that allows both me and my wife to see each other’s calendars and its been working great. Now, I want to be able to see my calendar from my iPhone 4 (with OS 6.1) .. and I’ve tried setting it up with: Settings / Mail, Contacts, Calendars / Add Account… / Other / Add Subscribed Calendar. With every possible configuration I can think of, I get the same response:

Calendar Subscription — Unable to verify account information

For server name, I’ve tried actual servername, IP address, etc; we do have security on the server but I put in the account name and password … ‘nuthin! Unable to verify. Through the phone's browser, I am able to open up the folder on our server and see the .ics file. The path is

xxxx.homeserver.com/webcal/nat_calendar.ics.

I've tried sending an invite to myself, opening it in the phone, clicking on the link and I get this error:

Cannot Subscribe: Could not subscribe to the calendar nat_calendar.ics from myservername.

Seems simple. What am I missing here? Any ideas?

share|improve this question
2  
Have you read apple.stackexchange.com/questions/56651/… Does it apply to your case? –  Global nomad Feb 15 '13 at 20:11

3 Answers 3

I found the answer to my particular issue. The reason that my iPhone could not subscribe to a published Outlook .ics calendar was because the MIME type of the .ics file was wrong. As recommended in this brilliant post by Joe Bradford, I went into IIS, changed the MIME type from application/octet-stream to text/calendar, and iPhone could connect and subscribe without further issue. Success!

PS: I did not run into the second issue that Joe chased down, which was having to remove the Byte Order Mark (BOM) from the .ics file via a hexadecimal editor.

share|improve this answer

In most cases, you only have to slide the calendar to 'ON' in your exchange settings. Settings > Email, contacts, > your account > switch Calendars to ON.

simple as that.

share|improve this answer

I usually send my invitations from Thunderbird. I was having the same problem with the ICS files after upgrading my iPhone 4s to iOS 7.

I did some experimenting and found out that if I turn off the "Support Outlook 2000 and Outlook 2002/XP" option in the E-Mail Notification dialog, the ICS file works on the iPhone; however, if that option is turned on, then the iPhone can't open the ICS file.

Note that this worked fine in the latest iOS 6 build (I always had the Outlook option on). So I would say that something is "broken" in iOS 7 regarding Outlook format ICS files.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.