Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

When I reply to a mail message, the reply is sent using the default email address as defined in mail.app, and not the email address that it was originally addressed to.

I have all accounts correctly set up and active.

To make it use the correct address, I need to manually select the account I want to send the email through. I am using OS 10.8 recently updated it. It did not happen with previous OS.

share|improve this question

2 Answers 2

After extensive reading at the Apple discussion forums, my feeling is that this is a BUG in Mail.app v6.2 (OS X 10.8.2):

In 10.6 & and 10.7 versions of Mail, when you hit "reply," it automatically chose the correct From: address, based on the To: field of the message you were replying to.

In 10.8, for messages that have been processed by rules (i.e. filtered automatically into local folders) this functionality is apparently broken.

See these very informative, exhaustive discussions:

https://discussions.apple.com/thread/4148125

https://discussions.apple.com/thread/4273912

share|improve this answer

This may be because a certain account is locked into a particular SMTP server.

  1. Open Mail Preferences by typing Command + , or Mail -> Preferences
  2. Click the Accounts tab.
  3. Click on an account and make sure "Account Information" is selected.
  4. In the "Outgoing Mail Server" section, make sure the "Use only this server" is not checked.
  5. Do this for every account.
share|improve this answer
    
Unfortunately does not work. Tried this... and same result... –  user41795 Feb 13 '13 at 18:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.