Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'm trying to share a calendar with my partner, and she is attempting to do likewise with me.

The first issue is that when sharing a calendar you do not get to select a permissions level, which has to be amended after it has been shared from the default or read/write to view only. There's no fix for this that I know of, it's just annoying and worth a feature request.

The second issue which is more annoying is that the permissions level for either calendar is reverting back to read/write no matter how many times I ask it to use view only.

I've attempted to change from iPhone/iMac and Web, and the same issue each time.

I've removed sharing access full stop and then re-shared the calendars, no luck.

I do have a shared calendar with someone else that has stayed in view only, but that was shared ages ago so I don't know what I might have done differently then.

Any clues what to do to fix this?

share|improve this question

3 Answers 3

The only way I managed to change the permissions was via icloud.com. OS/X and iOS did nothing.

share|improve this answer

Are you by any chance a user of BusyCal? I have been getting very frustrated with the same problem. However, I yesterday updated from BusyCal 1.6.something to BusyCal 2, and the problem seems to have gone away.

share|improve this answer

Changing the permission level should be possible from www.icloud.com If that does not work you can turn of shareing from there and reinvite the person. If you do it from the website you should enter the emailadress first, than change the permission to "view only" and finally click "done". You don't have this option when trying to do it from within the Calendar App in OS X.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.