Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Can anyone explain how to build Emacs --with-ns and SVG support on OS X?

Notes:

  • --with-rsvg isn't working (when librsvg is installed, ie. via Homebrew)

  • FYI, The Emacs Mac port uses webkit to provide SVG support, although that build adds far too many things I don't want.

I want to just compile in support for SVG on Cocoa Emacs, I'm not averse to patching, and if no answers are available, I'll see if I can patch over from the Emacs Mac port

(Assume latest stable version of Emacs 24.2, building from source)

Update:

I've tried running brew install emacs --cocoa --svg without success.

share|improve this question
    
I'm sorry, perhaps this question is off topic here (see FAQ). Please post to stackoverflow.com. Thanks. –  Global nomad Feb 12 '13 at 21:26
2  
@Globalnomad - raised on meta. - also see –  Slomojo Feb 12 '13 at 21:43

2 Answers 2

up vote 1 down vote accepted

The installation of the Emacs latest version (25.0.50) works fine using this command:

brew install emacs --HEAD --use-git-head --cocoa --with-gnutls --with-rsvg --with-imagemagick
share|improve this answer
1  
Good news. Still, now I'm hooked on Emacs Mac Port's pixel scrolling. I'll give it a go anyway. Thank you. –  Slomojo Nov 19 at 11:21
    
Yes, that’s the only downside. On the other hand I often had the problem that pixel-wise scrolling was sluggish. Line-wise scrolling is on the other hand a little bit too sensitive, but I also got used to it pretty quickly- –  mcb Nov 19 at 20:57
    
I tried building, however I got ranlib: file: libgnu.a((u64|unistd).o) has no symbols errors. –  Slomojo Nov 21 at 4:33
    
Try brew update, then brew upgrade (might take a while) and finally the Emacs install command above. If it still does not work, try running brew doctor and see if there is something broken. –  mcb Nov 21 at 5:59
    
Tried all those already unfortunately. Only Quartz is out of date, I will update it and try again. –  Slomojo Nov 21 at 6:45

I was unable to get this working, and instead went with the Emacs Mac Port

Turns out it's much better than I'd thought.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.