Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I just logged into Gmail and noticed that the last note to sync was from 6 days ago, even though I have newer notes on my iPhone.

When I try to test it now by deleting, updating, or adding a note, it does not sync with Gmail. I have 355 notes on the iPhone, and 350 in Gmail.

I seem to recall that after pressing the done button in the Notes application, the working indicator would appear showing that there is network activity (i.e. that it's syncing with Gmail). It no longer shows the spinner when I press "Done".

I tried restarting the phone to no avail. I tried deleting an email in Gmail in case there is a 350 limit, but that didn't help either. I also tried deleting notes on the iPhone so that it had less than 350 (in case the iPhone had a 350 limit), it didn't solve the problem.

I didn't change anything with the account setting on the iPhone nor on Gmail. I'm running an iPhone 4 with iOS 4.2.1. My iPhone is connected to the internet via Wi-Fi.

share|improve this question

3 Answers 3

The problem is that Google's implementation of IMAP isn't really 100% IMAP, so it doesn't really support notes. I've been trying to get it to work for quite a while which ended up with me losing all my notes (although they may still be in the Google Mail archive somewhere).

I've actually given up trying to sync notes between my Mac/iPhone/Google and have gone for the Plain Text app which stores the notes on DropBox, this seems to work so much better. Now if only I could delete the Notes app from my iPhone.

share|improve this answer
up vote 0 down vote accepted

I'm not sure what fixed it (restarting the phone? waiting a few days?), but now the sync is back to normal and I see the spinner icon whenever the notes are updated.

share|improve this answer

In GMail, I just removed my Notes label (dumping the prior notes into the general archive, probably a bad idea in retrospect not to give them a second label). In a bit, the Notes label was back, updated with notes.

I had this issue since April. This was attempted on iOS 7.1.1.

Data point: I had sublabels under Notes. Those sublabels have been there for a while, though.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.