Sign up ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'm stumped. I cannot get the HTML I wrote to display! I followed all the steps properly with creating a webarchive file, renaming so that it shows up in Apple Mail. But then when I go back in and see the signature, it's there but it doesn't display the HTML ... it just displays the code!

I've tested the HTML code on a webpage, and it works just fine. I have my message format as Rich Text.

The code is:

<a href="" ><img src="" /></a></center>
share|improve this question
Have you seen this question elsewhere on here?:… –  Philip Regan Sep 22 '11 at 15:55

2 Answers 2

You don't specify the steps you used so in case you missed something, take a look at this page describing how to set up HTML mail signatures.

share|improve this answer
I followed all those steps exactly. This is what I see when I look at the .webarchive file I made: I made it in TextEdit and saved as .webarchive, but I also tried doing it in Word as an .html then bringing that into Safari to make it a .webarchive. Both ways, same weird problem... –  user3539 Feb 12 '11 at 0:24
up vote 0 down vote accepted

OK, I figured out the problem, thanks to someone on the Apple forum!

When I was typing out the file in TextEdit, I needed to use the setting Format > Make Plain Text (or use a pure text editor like Text Wrangler). That was messing up the whole process. Now it's working!

Here's that thread:

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.