Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have just moved over to a Macbook Pro from my old Macbook. Thanks to the Migration Assistant, it was an easy task, but I am now having an annoying issue: I have both computers on with all the same settings and everything identical. The wifi settings, the Energy Saving settings - everything.

Now, when the computer goes to 'Sleep', the behavior is different is between the two computers. I have Skype on. If I'm away for about an 1 hour, Skype will go offline. As a result if someone were to Skype me, the old Macbook will react - my Skype will ring when they call me and obviously they see me as online (despite the screen being off and the computer in sleep mode).

However, my new Macbook Pro will not ring. The party that wants to reach me will think I'm offline because the network connection gets disabled somehow. On my old Macbook, I just need to touch the trackpad and the screen comes on, but on my new Macbook pro I need to press a key (some websites state that this is the new thing on new version such as Lion and Mountain Lion), and the computer will quickly come on, pick up the wifi and only then all e-mails and Skype lines/calls will filter through and I will reappear as online.

How can I stay online even when my computer goes to sleep?

share|improve this question
2  
Is the box Wake for network access checked in the Energy Saver preferences under the Power Adapter tab? –  Bart Arondson Feb 11 '13 at 17:33
    
yes, it is. Both computer settings are identical but the 'behaviour'differs :( –  user41625 Feb 12 '13 at 8:30

2 Answers 2

There are a couple of things that could be causing this:

  1. Make sure "Wake for network access" is checked in Energy Saver. This should work if Skype is sending data over Bonjour.Screenshot of Energy Saver control panel with wake for network access highlighted

  2. Your prior computer may only be turning off the display instead of sleeping the computer entirely. In the Energy Saver control panel, try setting the computer sleep time to Never. You can retain your display sleep time.

My understanding is that #2 is likely the solution as I don't believe the type of traffic on which Skype relies will trigger the Wake-On-LAN feature.

share|improve this answer
    
Thank you so much for your answers....yes, both computers have the above mentioned box checked....and energy settings are set in the same way on both computers...I have it at 15 min. As mentioned before, I have identical setting on both computers...but say i have not touched both computers for 1 hour and someone calls on Skype, the old computer will ring and the new will not ! Beats me haha –  user41625 Feb 12 '13 at 7:59
    
I have read that putting the settings as NEVER is not good for the computer ? I might just put the computer sleep to NEVER and keep the display sleep at 10 min. However, that still does not answer my question why one mac sleeps and the other remains active –  user41625 Feb 12 '13 at 8:33
    
Can you verify that the computer is actually sleeping? Perhaps it's a setting on Skype; If the computer is set to never sleep, it should not sleep. Perhaps there is another setting or program which is putting it to sleep? –  zwerdlds Feb 12 '13 at 15:33
    
As for the concern about not sleeping, I believe the least durable parts will still be sleeping: the screen and the HDD. You really don't have much to worry about AFAIK. Your power bill might be a bit higher but that comes with the question's territory anyways. That IS what you're asking to do. –  zwerdlds Feb 12 '13 at 15:35
    
well, two computers, same settings, same wifi, I have them on my desk....one is sleeping...the other one is receiving e-mails ( you can hear the click ) and if anyone sends skype msg or calls, one computer responds while the other one is sound asleep....I know, it's one of these weird scenarios ! If I set the setting to NEVER sleep, it stays awake ! –  user41625 Feb 12 '13 at 18:11

Have you tried disabling standby mode?

sudo pmset -a standby 0

Some newer laptops enter a lower energy mode after about an hour of normal sleep under certain conditions. I don't know if it also disables waking for network access though.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.