Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'm currently using a Macbook Pro and wanted to play a game and came up with Warsow. I downloaded it, dropped the app in my applications folder (is it even called folder on Macs?^^). As soon as I started the game I noticed my mouse sensitivity was significantly lower. I opened the options and played around with the ingame sensitivity and it didn't change my mouse speed at all.

After quitting the game and looking up my mouse settings in the system preferences it was set to 0 (or the lowest possible setting on the slider).

Important notices:

  • I'm using a "Gaming" mouse (Speedlink Kudos), which works fine. Even some of the side button settings I made on my Windows machine work properly. Also the DPI change works. Sadly Speedlink only provides Windows drivers
  • I'm using "Kill Mouse Accell" app by adding "Automatic Kill Mouse Accell" (Apple Script) to my starting objects. This is intended to "disable" the nasty mouse accellaration of Macs.

Warsow related results:

The only search result related to Warsow on Macs is this forum posting on warsow.net:

Disabling that !"#€%&/ mouse acceleration, is it possible?

There are several ways to make this darned broken mouse acceleration more tolerable.

First way is to use built-in hack in Warsow to disable it (same as in NQuake/QuakeWorld Mac version): in_disablemacosxmouseaccel 1 and restart Warsow

Known bug with this is that this also resets mouse sensitivity setting to zero on some Macs.

(source: http://www.warsow.net/forum/thread/11839/1)

However no comments relating this particular issue were made in the answers. Same with search results.

My question:

I don't really know what to do. What may solve my problem? Or if it can't be solved, how to counteract? (Maybe with an apple script bound to a shortcut which sets the mouse sensitivity back to normal?)

share|improve this question
    
Do you use a special driver/utility for your Gaming mouse? –  patrix Feb 10 '13 at 18:43
    
@patrix No, nothing at all since there isn't anything provided by Speedlink. –  kleinfreund Feb 10 '13 at 19:07

1 Answer 1

up vote 0 down vote accepted

I've managed to solve this problem on my own.

Warsow has a built-in "hack" to disable Mac OS X mouse accelleration, which is on by default. This is redundant to using my "Automatic Kill Mouse Accell" script on startup and causes this problem.

solution:

Open Finder and navigate to your user folder /Library/Application Support/Warsow-1.0/basewsw/ and open the config.cfg file. Search for seta in_disablemacosxmouseaccel "1" and replace it with seta in_disablemacosxmouseaccel "0".

source: http://www.warsow.net/forum/thread/t/216237#post-216237

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.