Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

For some reasons I can't adjust the volume on my iPhone 4 anymore. Whenever I press it the popup showing the bell is shown but not the bar indicating the . I can't adjust the volume at all. Also playing music in the musicplayer doesn't work anymore. The play-symbol is shown but I just can't hear a thing.

Does anyone have a clue what is going wrong?

showing non working volume-rocker

share|improve this question
    
Have you tried doing a shut down? Holding the power button till it asks to shut down... that would be my first thing to try... –  TheX Feb 8 '13 at 20:23
    
Just tried it. Didn't work. –  Hedge Feb 8 '13 at 20:26
    
odd, is it jailbroken? –  TheX Feb 8 '13 at 20:27
    
no it's jailbroken. –  Hedge Feb 8 '13 at 20:33
3  
For future viewers: "Klingelton" is the German equivalent to "ringer" in English. –  Emil Feb 8 '13 at 21:12
show 4 more comments

6 Answers

The other answer is correct in saying that it thinks it is plugged into something. It could either be the headphone jack is busted, or more likely, you disconnected the iPhone from your computer without ejecting it.

A simple fix (hopefully) is to plug the iPhone into your computer and make sure it can be viewed in iTunes. Once that happens, eject the iPhone and attempt to change the volume.

It worked for me.

share|improve this answer
add comment

You can try using the Assistive Touch which is found by going to:

Settings -> General -> Accessibility -> AssistiveTouch

Turn that on and you should find a dot looking like this:

enter image description here

Click on it, and go to Device and then try turning the volume up and/or down.

enter image description here

enter image description here

share|improve this answer
add comment

This might be caused by several things, one of them being your phone believing it's connected to an external speaker through the 30-pin connector. When your phone believes it's connected to an external speaker, it assumes the speaker controls the volume, so you can't control the volume. In addition to that, the phone will attempt to transmit any audio through the 30-pin connector. I can't really think of any solution, other than trying to connect and disconnect from a charching cable or docking station, or try a restore.

I assume you've already attempted to reboot the phone, another thing you could try is to connect it to some headphones with the mini-jack port and see if you're able to control the volume with them plugged in. If you have a cotton swab that can fit in the 30-pin connector, you can also try to clean it (do NOT use water, soap or acid, simply a dry, clean swab).

If nothing helps, I suggest you hand it in for a check-up at the nearest Apple Retail store.

share|improve this answer
    
As I mentioned in another comment - I'd prefer a soft toothbrush rather than cotton swabs which could leave cotton behind. Pure alcohol (less than 1% water or other ingredients) is fine to use as well on the brush if needed. –  bmike Sep 2 '13 at 22:19
add comment

I just fixed the same issue with my iphone, to fix it i use wd-40 + brush. Several drops of wd-40 to 30pin connector wait a few seconds and clean connector with a brush. After that clean up connector from wd-40 and it's works great:)

share|improve this answer
    
Welcome to Ask Different. This doesn't appear to be related to the question asked - the 30 pin connector would not affect using the volume controls or hearing output from the speakers. –  tubedogg Sep 2 '13 at 21:29
    
Actually, I've seen corrosion and shorts on these pins cause all sorts of wonky control issues. I would probably not use any solvent on the pins except very pure rubbing alcohol, but WD-40 would be better than water although I'd be worried about a heavy application or it getting inside the case. A dry toothbrush with soft bristles and a light touch should clean the dock connector sufficiently for most people. –  bmike Sep 2 '13 at 22:17
add comment

I found a totally bizarre solution to the problem where on earphones, audio worked fine, but on the iPhone 4s speaker no app audio and no music. Could not adjust volume, icon appeared without slider.

My fix (I think): was to re-setup "Find iPhone" (the lost iPhone app) activate it and then page find the phone. I got sound out of the iPhone speaker and problem has not recurred - been about 10 days now.

None of the other things worked: changing cable connector, cleaning and so forth.

share|improve this answer
add comment

I had exactly the same problem (volume on earphones only, no speaker audio control) and tried the "find iphone app" solution mentioned above. It works great! What a mystery...

Steps: go to "find iphone" app, login, select your device, select "send alert"

share|improve this answer
add comment

protected by Community Sep 21 '13 at 11:08

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.