Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

When I downloaded an application (e.g. RubyMine) and transfered it to the Applications folder, the application wont start (nothing happens). It is not limited to the Applications folder, it appears for every directory I unpack the downloaded app (out of the .dmg).

When I type open RubyMine.app in the Terminal, I get:

LSOpenURLsWithRole() failed with error -10658 for the file /Applications/RubyMine.app.

And it happens with more apps then only RubyMine.

What can I do about this? At the beginning i was asked to allow the startup of the downloaded app, but now this appears every time.

share|improve this question
It looks like this only happens to Java programs, but I can't say that for sure. –  Adam S Feb 7 '13 at 5:15

1 Answer 1

up vote 12 down vote accepted

This seems to be a problem with permissions in the bundle itself. Usually the execution flag doesn't get carried over from the DMG image.

Try, for the sake of curiosity to set the execution flag like this:

chmod +x /Applications/RubyMine.app/Contents/MacOS/<name of the app>

Note: replace <name of the app> with the name of the app (it will probably be "rubymine", but I don't have that app to confirm the exact name of the binary.

If you're in doubt, right click on RubyMine.app, do a "Show Package Contents" and navigate to Contents/MacOS/ folder and see what's in there. Perform the above command (chmod +x) on that file and try again.

I think it should be:

chmod +x /Applications/RubyMine.app/Contents/MacOS/rubymine

update: I've downloaded RubyMine and the above command will work, however, for what is worth, I've got to say that mine had the execution flag so I didn't have any problem with it. Have you checked?

share|improve this answer
It worked, thanks! –  Adam S Feb 7 '13 at 22:15
Glad to hear it Adam! –  Martín Marconcini Feb 8 '13 at 0:54
Currently, I'm having the problem WITH +x being set for everyone. –  Max Ried May 6 '14 at 21:33

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.