Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have an iPhone and an iPad, both with iOS 6.1. I use iCloud for calendar syncing between them and my Mac. For whatever reason, the iOS devices don’t sync calendars with iCloud unless and until I open the Calendar app on the device. Is there any way to change this behavior so that iOS checks for calendar changes without my intervention?

(This is very annoying for two reasons: I set alarms on events frequently, but each time I do this on my computer I have to remember to launch Calendar on my phone or else it won’t know about the new event and it won’t remind me. Moreover, I don’t even use Calendar—I use Fantastical on the phone and Calvetica on the iPad—so it’s out of my way even to launch the Calendar app.)

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

Navigate to: Settings > Mail, Contacts, Calendars > Fetch New Data

And set:

  • Push = ON
  • Fetch = (as often as you like)

Move to Advanced, and set iCloud to Push

share|improve this answer
add comment

Checklist:

  1. Check your Calendars setting on iOS (accessible from the Settings->iCloud) by ensuring your iCloud account details in correct. Then
  2. Check the Calendars Sync setting on iOS (accessible from Settings->"Mail, Contacts, Calendars" settings on iOS). Also touch the > symbol to the right of "Fetch New Data" setting to ensure Push is ON and set to fetch at an interval you prefer (every 15 minutes, etc.) You can even use the Advanced section to select which email you want to Push or Fetch.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.