Sign up ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I installed iTerm2 the other day, and was playing around with it. In the process I seemed to have messed up the handling of HTTP hyperlinks on my system. Sometimes (annoyingly, not every time, which is very confusing - I can't spot a pattern) when I click an HTTP link in the Twitter app, MS Word, and so on, it opens a new iTerm2 terminal window or tab, and the webpage doesn't open. How can I get back to the original behavior and have the link open in the default web browser?

I've already checked the iTerm2 preferences - under "URL schemes", no scheme is selected:

enter image description here

share|improve this question
Try to reassign the URL schemes using RCDefaultApp. –  Daniel Beck Feb 5 '13 at 17:02
If there is an entry for it in ~/Library/Preferences/, try deleting it and restarting. –  ؘؘؘؘ Feb 5 '13 at 17:30
Lauri, your answer worked. https (not http) was associated with iTerm2, not Safari - hence the "random" behavior. I've fixed that now. If you change your comment to an answer, I can mark it. –  Andrew Ferrier Feb 5 '13 at 19:08
Andrew, could you copypaste the solution to an answer and mark the question as solve, please? I'd rather not steal Lauri's reputation but it's preferable you get it than I do. –  GhostLyrics May 13 '13 at 16:03

2 Answers 2

up vote 1 down vote accepted

Check the file associations for both HTTP & HTTPS, make sure both are set to Safari.

A simple way to do this would be using RCDefaultApp

enter image description here

Answered as Community Wiki just so we don't have a dangling question when there's a perfectly good answer in the comments.

share|improve this answer

Set Safari to be your default web browser.

share|improve this answer
How do you do that? –  Mark Jun 28 at 14:34

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.