Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

My MacBook drives my external DVI monitor (over mini display port, using Apple's adapter) just fine, but it fails to detect changes in the display configuration and doesn't react accordingly unless I manually "detect displays" in System Preferences. It fails to detect both a display being plugged in, AND being unplugged. Anybody know how to troubleshoot/fix this?

I have already:

  • Reset NVRAM (fun fact: PRAM is only in PowerPC Macs, in Intel Macs it's called Non-volatile random-access memory)
  • Reset SMC
  • Cleaned the Mini-Display Port connector (male and female end).

Edit: this set up had been working well for over 2 years and randomly started exhibiting this behaviour recently.

share|improve this question
    
1) What is the model of the external DVI monitor? 2) What is the configuration that works, what configuration change(s) isn't detectable? –  Global nomad Feb 4 '13 at 4:21
    
It's an LG Flatron W2343T if that mattered lol. –  XAleXOwnZX Feb 4 '13 at 5:05
    
And it works fine (in terms of display output contents), but my macbook just fails to adapt between the single monitor and dual monitor configurations. It seems to not "notice" the plugging in and unplugging of the monitor. –  XAleXOwnZX Feb 4 '13 at 5:06
    
Your question suggest you've already done what's recommended in support.apple.com/kb/HT1573. I asked the two questions because I was unsure if you've checked support.apple.com/kb/… –  Global nomad Feb 4 '13 at 5:15
    
I should have mentioned that this set up has been working for over 2 years and randomly started exhibiting this behaviour recently. –  XAleXOwnZX Feb 4 '13 at 5:22
show 4 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.