Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Is there any way of suppressing the alert dialog that pops up when restarting a crashed program in Mountain Lion (10.8.2)? The alert's text reads:

"The last time you opened , it unexpectedly quit while reopening windows. Do you want to try to reopen its windows again?"

I want the OS to just open the program without asking me this, since the computer is being used in a kiosk-type application.

Thanks,

c.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

defaults write com.apple.CrashReporter DialogType none (or the option in Secrets) disables crash report dialogs but not the dialogs shown when reopening crashed applications.

Disabling Resume would remove them though. You can either check "Close windows when quitting an application" in the General preference pane or disable it in individual applications with defaults write -app "Application Name" NSQuitAlwaysKeepsWindows -bool false.

share|improve this answer
    
That did the trick, thanks!! –  trip Feb 11 '13 at 22:20
    
And for completeness, for this to work one needs to check the box, open the program in question and immediately close it. On the next re-opening it will work without Resume. –  trip Feb 13 '13 at 12:27

There is a Preference Pane called Secrets that has an option under "System" called "Crash Dialog". Mine is set to "none" and I never see that dialog. Maybe that will work for you.

http://code.google.com/p/blacktree-secrets/

share|improve this answer
1  
Thanks for that, but unfortunately it doesn't solve my problem. While the crash report is indeed suppressed, reopening the program still prompts the dialog box in question. Again, it is not when the application crashes, but when it is reopened, when the issue shows up. –  trip Feb 11 '13 at 22:14
    
I had the Close windows box checked too already! –  mkaz Feb 12 '13 at 22:49
    
Heh, thanks for the Secrets Pref Pane though! –  trip Feb 13 '13 at 12:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.