Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'm having an issue trying to access administrative shares on my Windows 8 PC from my MacBook Air running OSX 10.8.2.

Here is the process, errors and background info:

  1. On the MacBook, Go menu > Connect to Server > Server Address: smb://megaman/c$ > Connect
  2. Connect as: Registered User > Name: Zach; Password: my password [This is an admin account on the Windows 8 PC]
  3. "There was a problem connecting to the server "megaman". You do not have permission to access this server.

Ok, fine....So as a sanity check, I make sure the administrative share (c$) exists on the Windows8 PC, and that the 'Zach' account is a member of the Administrators group. That all checks out. Next, I create a new share of the 'c' drive on the Windows 8 PC and in the share settings, only give the user account 'Zach' Full permissions.

I run back through steps 1-3, but this time I just enter 'smb://megaman' for the server address. I get the 'Select the volumes you want to mount on "megaman"' dialog box on the MacBook and 'c' is listed as a share. I select 'c' and click OK. The share mounts without error.

I've also tried mounting the c$ share via command line and get a "Permission denied" error. I've tried disabling the firewall, but this doesn't make any difference. I've tried deleting and recreating the administrative share, and also creating a new admin account on the Windows 8 PC, but none of those make any difference either.

Perhaps it's a setting in local security policy on the Windows 8 PC? I can't say for sure, but my guess is that this issue began with Windows 8, since I used to be able to access the c$ share when my PC ran Windows 7.

share|improve this question
    
Love the "Megaman" name for your server! –  Andrew J. Brehm Oct 10 '13 at 17:55
add comment

1 Answer

up vote 4 down vote accepted

Administrative shares have been disabled in Windows Vista and later versions of Windows for security reasons.

According to Microsoft Support Knowledge Base article 947232, you can do one of the following:

  1. Create your own shares with the appropriate permissions (recommended);

  2. Run the Microsoft Fix It to perform an automatic workaround; or

  3. Add to the Registry subkey HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System a DWORD (32-bit) Value LocalAccountTokenFilterPolicy entry with the value data of 1.

share|improve this answer
    
Yep, you nailed it. Read up on the KB article and creating the LocalAccountTokenFilterPolicy entry does let me access the administrative shares. Thanks. –  zsaltzman Feb 18 '13 at 0:37
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.