Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I am getting a system message from Mac OS x 10.8.2 every time I power on my ICY DOCK RAID enclosure. I have followed the procedure in the manual to the letter.

Installed two new 2TB HDDs > Changed DIP switch to RAID Mirror mode > powered on unit > Reset unit > let unit "rebuild" and "verify" for 24 hours. After RAID was created I partitioned the volume using Apple Disk Utility and checked it for errors. None were found. Unmount the new volume and power off enclosure. Upon starting up the enclosure I get the system warning, "The disk you inserted was not readable by this computer." "Initialize…" "Ignore" "Eject". If I choose to initialize the same loop occurs regardless.

The odd thing was that the volume does mount correctly, in the background, after the warning message pops up. So I wanted to see what was happening during disk arbitration. I tried two different physical setups. One was with USB plugged in while the enclosure booted and one was with USB initially unplugged then plugged after the drives spun up and the indicator lights stabilized. (Interestingly the second setup doesn't elicit this warning.)

I ran diskutil activity in Terminal with the enclosure connected via USB while powering up.

***DiskPeek ('disk2') Time=20130131-10:49:54.2147
***DiskAppeared ('disk2', DAVolumePath = '<null>', DAVolumeKind = '<null>', DAVolumeName = '<null>') Time=20130131-10:49:54.2170
***DAIdle (no DADiskRef) Time=20130131-10:49:54.2172
***DiskDisappeared ('disk2', DAVolumePath = '<null>', DAVolumeKind = '<null>', DAVolumeName = '<null>') Time=20130131-10:49:55.1328
***DAIdle (no DADiskRef) Time=20130131-10:49:55.1330
***DiskPeek ('disk2s2') Time=20130131-10:49:57.4184
***DiskPeek ('disk2s1') Time=20130131-10:49:57.4204
***DiskMountApproval ('disk2s2', DAVolumePath = '<null>', DAVolumeKind = 'hfs', DAVolumeName = 'TimeMachine') Comment=Approving Time=20130131-10:49:57.4214
***DiskAppeared ('disk2s1', DAVolumePath = '<null>', DAVolumeKind = '<null>', DAVolumeName = '<null>') Time=20130131-10:49:57.4218
***DiskPeek ('disk2') Time=20130131-10:49:57.4230
***DiskAppeared ('disk2', DAVolumePath = '<null>', DAVolumeKind = '<null>', DAVolumeName = '<null>') Time=20130131-10:49:57.4266
***DiskAppeared ('disk2s2', DAVolumePath = 'file://localhost/Volumes/TimeMachine/', DAVolumeKind = 'hfs', DAVolumeName = 'TimeMachine') Time=20130131-10:49:57.5624
***DAIdle (no DADiskRef) Time=20130131-10:49:57.5626

I ran diskutil activity in Terminal with the enclosure disconnected while powering up.

***DiskPeek ('disk2s1') Time=20130131-11:13:47.1215
***DiskPeek ('disk2s2') Time=20130131-11:13:47.2001
***DiskAppeared ('disk2s1', DAVolumePath = '<null>', DAVolumeKind = '<null>', DAVolumeName = '<null>') Time=20130131-11:13:47.2035
***DiskPeek ('disk2') Time=20130131-11:13:47.2039
***DiskMountApproval ('disk2s2', DAVolumePath = '<null>', DAVolumeKind = 'hfs', DAVolumeName = 'TimeMachine') Comment=Approving Time=20130131-11:13:47.2045
***DiskAppeared ('disk2', DAVolumePath = '<null>', DAVolumeKind = '<null>', DAVolumeName = '<null>') Time=20130131-11:13:47.2097
***DiskAppeared ('disk2s2', DAVolumePath = 'file://localhost/Volumes/TimeMachine/', DAVolumeKind = 'hfs', DAVolumeName = 'TimeMachine') Time=20130131-11:13:47.3464
***DAIdle (no DADiskRef) Time=20130131-11:13:47.3466

In the first scenario the volume mounts and then un-mounts (this is when the system message is shown) and then remounts and all is well except for that dangerous "Initialize…" button still facing users.

I am not intelligent enough to decipher the clues, but would like to fix it.

I do have an idea that is has to do with the older storage processor used in the RAID enclosure. This was produced in 2007 during the era of PPC, Mac OS X Tiger, and Leopard. Since then Apple might have changed their disk arbitration daemon to handle Intel processors and EFI.

Looking at the Silicon Image website, the latest software available for managing and flashing the SiI5744 Storage Processor, SteelVine Manager, is from 2008 and only runs on Mac OS X Tiger or Leopard. It requires Rosetta or a PPC processor to run because the software uses PPC code. I could install Leopard on another partition just to run this software… but until I am sure that will solve the issue I ain't gunna.

Sorry for the long post. I can add more info. Maybe run diskutil info on the RAID volume in question if someone makes a request.

Thank you.

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.