Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have two active keyboard layouts - US english and russian. I have russian as my primary system language and the option "allow different input language for different documents" is active. But when I open any app keyboard automatically switches to russian, while I want it to be english by default. Is there any way to change the default keyboard layout without changing system language?

share|improve this question
    
What system are you on? On my Mac running Mavericks newly started apps just keep the keyboard layout that was selected before. –  codingFriend1 Feb 11 at 15:17
add comment

2 Answers 2

When I tried enabling the setting (Input source options: Allow a different one for each document), new windows seemed to just use the current input source.

Anyway, you could try running sudo /System/Library/CoreServices/Setup\ Assistant.app/Contents/MacOS/Setup\ Assistant and selecting US as the default input method. (You have to go through the steps of creating a new account, but you can delete it later.) It modifies at least /var/root/Library/Preferences/ByHost/com.apple.HIToolbox.*.plist.

If that doesn't work, try running sudo languagesetup and selecting English, or sudo defaults write /Library/Preferences/.GlobalPreferences.plist AppleLocale en_US and restarting.

share|improve this answer
add comment

enter image description hereTry the option Use the same one in all documents and with a keyboard shortcut you can easily switch between different input methods, for example, Cmd + Space.

share|improve this answer
1  
It's kind of difficult to understand what you propose to do here, especially the part between the "" –  patrix Jan 31 '13 at 19:01
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.