Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

During the Mountain Lion installation I have selected the English language as the system language. However, the dialog asking for my password – that appears when you need to install an application, or when you want to unlock a preference pane – is in Dutch. I'm currently in The Netherlands, but I don't see how this might be related to the language of one type of dialog.

Here below an image of the dialog. As you can see there's even a mix of Dutch and English: enter image description here

I haven't been to other countries yet with this MacBook Pro, so don't know if it's actually dependent on location.

How can I fix this issue?

share|improve this question
add comment

3 Answers 3

up vote 1 down vote accepted

In the end I solved the problem by removing all languages except English from the list found in System Preferences -> Language & Text and restarted.

share|improve this answer
add comment

I've encountered the same in Netherlands. I just switch the language once OSX installation is complete (and before I run Migration Assistant).

share|improve this answer
    
Do you mean that you switch the language in the language and text pref panel? I have English as the first, and Dutch as the second. Removed Dutch from the list, but the problem persists. I have already used migration assistant to migrate from a SL install. I only migrated the User folder, not the settings. –  Bart Arondson Jan 30 '13 at 20:17
    
Yes, that's what I mean. I let the OSX install complete until I see the desktop, then I change the language setting in International preference pane and reboot. –  Global nomad Jan 31 '13 at 6:18
    
I did this, but it didn't solve the problem. –  Bart Arondson Jan 31 '13 at 6:55
    
Everything still in Dutch despite language set to English? Even after reboot? –  Global nomad Jan 31 '13 at 8:15
1  
let us continue this discussion in chat –  Bart Arondson Jan 31 '13 at 8:58
show 3 more comments

A few things you could try:

  • Run sudo languagesetup, select a new language, and restart.
  • Run sudo defaults write /Library/Preferences/.GlobalPreferences.plist AppleLocale en_US and restart.
  • Run sudo /System/Library/CoreServices/Setup\ Assistant.app/Contents/MacOS/Setup\ Assistant, go through the steps of creating a new account, restart, and delete the account.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.