Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

iPhone 3GS, iOS 6.01
Macbook Mac OS 10.6.8

The iPhone 3GS hotspot works fine via Bluetooth, connected to my iPad.

If, instead, I tried it with my Macbook via USB (can't do it via Bluetooth for another reason), if I open the network preferences I can see the iPhone but it says that the cable is not connected or the device is not responding. Of course the cable IS connected and iTunes correctly sees the iPhone.

I've never tried tethering before on my macbook. I haven't tried other solutions.

enter image description here

Any clues?

share|improve this question
    
Would you be willing to edit your question and post screenshots, and more details on what you found in researching and troubleshooting the problem? I would guess that there would be a number of things that could be causing the problem. Has tethering ever worked with your MacBook? – bassplayer7 Jan 29 '13 at 14:07
    
done. I can't post images though, because I'm new. Here is the URL of the screenshot dadabik.org/screen.png – Eugenio Jan 29 '13 at 14:36

Somewhere around late 2014 is got very reliable for me. I don't know if iOS changed, OS X changed or both, but before then I continued to have the problems you describe with Mountain Lion 10.8.4 and earlier.

Of late, this has been quite solid and at worst, toggling the connection in network preferences on OS X fixes any connection issues with iOS hotspot being solid in general.


Before the fixes, the problem seems to be a timing issue.

What I've found is that if the connection light doesn't show green, I want to disconnect the device and turn off tethering on iOS. After waiting 5 seconds or so, I turn on tethering again on iOS and be sure to leave the tethering screen showing. (don't leave the settings app) I then reconnect the device and listen for it to signal that it's connected with the chirp iOS makes when connecting to a computer. If the light doesn't go green in system preferences, I toggle the Personal Hotspot off, count a few seconds and turn it on.

Occasionally, something just isn't correct on the Mac end and I switch to Wi-Fi tethering and delete the interface in System Preferences and then start over with the set up.

I wish I could say this worked reliably for me, but it seems to be fidgety and prone to errors and lock up.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.