Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Can't get subject to work consistently. Some times I can access AirPlay on my Macbook Pro. On my iPhone (4S) and my iPad (3rd gen) I can't find the airplay icon.

The Home Sharing option has never worked - I have checked the firewall (it's off) and all units are connected to the same wireless network (a wifi extender)

Any ideas on how I can get to use the full potential of my new "toy" (The Apple TV 3rd gen)

share|improve this question

3 Answers 3

up vote 3 down vote accepted

The design of iOS isn't helping you troubleshoot this issue since it suppresses the AirPlay icon until a device detects a receiver on the local subnet.

Just being on the same network isn't enough, the devices need to see broadcast traffic that works best with IPv6 support and can also work when you only are routing IPv4 traffic.

The simplest thing to do is power off the extender and see if you can confirm that the two devices see each other.

Sadly, I don't see this documented well by Apple, but here is one article that explains you might not see the AirPlay icon due to network issues:

share|improve this answer
    
seems like they work if I'm on the same wifi network, as long as it's not the extender for some reason... Home Sharing just worked for the first time ever :o) –  noesgard Jan 28 '13 at 21:50
    
It's a common failing - when your extender reduces traffic, it can speed things up, but devices that need to chat amongst themselves need broadcast traffic to be really broadcast. For what it's worth, AirPort work well to support AirPlay - even with many devices extending one master base station. Look in your extender or router manuals to see if they can share mdns/bonjour/ZeroConf traffic and that might make things work for AirPlay again. –  bmike Jan 29 '13 at 0:45

I was too lazy to use the primary user password (manufacturer set password to hard to remember) when I set up my iPad at the beginning, I just used the guest password with my iPad. As a result of this, the airplay icon did not show up. Also, you need to add your iPad to the Airport devices too.

share|improve this answer

Home Sharing doesn't work with WPA2 security for some reason. If you look under system preferences/sharing/wifi options, you'll see what kind of security it's using.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.