Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My Mac Mini (2011) has always auto-joined networks worked fine until a few days when he stopped auto-joining my preferred WPA2 Wifi network when I start it up. When I click Join Other Network and then Show networks my wifi appears. When I double click it I have to enter my password than my mac joins it. But next time I start my Mac, I have to do that again.

How can I get auto-join to start working again?

share|improve this question
Not mentioned, so I think I should ask. Have you checked if your preferred network is listed in "System Preferences - Network - WiFi - Advanced - Preferred Network"? If yes, delete it and check the password. – Shane Hsu Jan 28 '13 at 15:56
Thanks but I have tried this already. (Sorry I have forgotten to Write that in the question) – idmean Jan 28 '13 at 16:09
up vote 2 down vote accepted

Well, now i can answer my question self.

Go to Keychain Access and remove all airport passwords for this network from Login and System keychains.

Then create a new password in System. Enter as password the network password. Item Name and account name: name of the network. Click add. Then double click the new item in list. Change kind to 'airport password'. Then click Access Control and select Allow all applications to access this item.

Restart your computer if it doesn't joins automatically join it manual, next startup it will works fine again.

share|improve this answer

Go to System Preferences / Network / Wifi / Advanced and remove your network from list of Preferred Networks.

Now go to Keychain Access and remove all airport passwords for this network from Login and System keychains.

Then restart your computer, join the network, select save password and remember network.

After that, it should join automatically.

share|improve this answer
Thanks but it hasn't helped. – idmean Feb 11 '13 at 13:24

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.