Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using a clean install of 10.8. I wanted to add a couple of directories to my path. I tried adding them to /etc/paths using

sudo vim /etc/paths

Now when I open a terminal window I see this:

Last login: Wed Jan 23 15:42:57 on ttys001
/etc/paths: Permission denied
pcp067952pcs:~ myLoginName$

This doesn't affect usability, however it is something I would prefer to fix.

Any ideas? -Austin

share|improve this question
I believe you changed the permissions by editing the path with root privileges. My privileges for that file are -rw-r--r-- 1 root wheel 105 Jun 26 2012 /etc/paths I hope this helps. Good luck. – jakebird451 Jan 23 '13 at 23:59
Check by seeing what ls -l /etc/paths gives – Mark Jan 24 '13 at 0:34
oh! yeah i totally messed that up. i think i chmodded it to 0400. mine says -r-------- 1 root wheel 45 Jan 23 15:43 /etc/paths. – austin Jan 24 '13 at 4:31

solved by repairing permissions, thanks to jakebird451 and Mark in the comments above

i'm not sure is sudo is necessary, however this worked to fix it

sudo chmod 0644 /etc/paths


share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.