Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

On Mountain Lion 10.8.2, when I use the Keyboard Viewer, I can see that CTRL-1, CTRL-2, CTRL-3 register correctly when I type them.

CTRL-4/5 however, only show the CTRL key being hit and the numbers ignored.

How can I enable all the CTRL-# keys?

I don't really need them for spaces - rather, I need all the keys available for SC2 (FWIW, CTRL-1, CTRL-2, CTRL-3 work fine in SC2, but the higher numbers don't).

share|improve this question
    
That's very strange. FWIW all those key combos work fine for me on 10.8.3. Did you check to see if the 4 and 5 keys register without modifiers? –  Elliott May 17 '13 at 8:57

1 Answer 1

I had a similar issue of unresponsive Ctrl+3 and Ctrl+4 keystrokes using OS X 10.8.4 and found a solution that worked for me using information from this answer.

  1. Open ~/Library/Preferences/com.apple.symbolichotkeys.plist (I used XCode).
  2. Update keys for the shortcuts which are giving you trouble by switching enabled to NO. I switched 120 and 121, which represent Ctrl+3 and Ctrl+4. I am not sure about Ctrl+5 or Ctrl+6.
  3. Restart your computer.

Hope this helps!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.