Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I got a brand new Retina MacBook Pro (2.6 GHz Intel Core i7, 16 GB RAM, Mountain Lion 10.8.2) a couple months ago, and it was buttery smooth (for the most part) at first.

However, one day I turned it on and I suddenly got some terrible lag issues. For example, when I opened the Notification Center sidebar, it stuttered and chopped on the sliding animation. Similarly, the Genie effect stuttered when I minimized windows. The list just went on and on. At first I thought this was a hardware problem (it also turned out the screen had been mis-aligned), so I brought it to the Apple store. They couldn't find anything wrong with the graphics chip, but it they decided to replace my MacBook because of the bad screen alignment. I got the replacement yesterday. I restored my previous system from a Time Machine backup using the Migration Assistant. Everything was buttery smooth again, and I thought the problem was resolved.

However, this morning, I fired up my MacBook again and all of a sudden, the lag is back. The fact that the lag was nowhere to be found right after the Time Machine restore, but then suddenly back after a reboot is mystifying.

Can anybody please shed some light on this situation? Thanks!

UPDATE: I have tried turning off "Automatic graphics switching" in the "Energy Saver" system preferences, but to no avail.

share|improve this question
1  
I am very interested in this myself. On my Late 2012 MacBook Pro, I have noticed basically the exact same problems. My computer also does this after reboots. Sometimes, after a reboot it is good, other times it has the shuttering effect. –  bassplayer7 Jan 22 '13 at 17:22
    
Yes! I've never had a reboot where the lag is gone, but I have observed that sometimes, the lag isn't as pronounced. Hmm. I am fairly confident in ruling out hardware as the problem (unless somehow both my original MacBook and the replacement MacBook both have defective graphics), which leaves the software. I really hope somebody has a solution to this problem! The lag is intolerable, and definitely not acceptable for any product, let alone an Apple product. –  Titus Jan 22 '13 at 17:26
add comment

2 Answers 2

up vote 2 down vote accepted

I successfully resolved the glitch/lag problem on my Retina MacBook Pro by re-installing Mountain Lion without use of the Migration Assistant. I have outlined my steps below:

  1. Backed up all my data to an external hard drive
  2. Completely powered off my MacBook
  3. Turned on my MacBook while holding down the "Option" key
  4. Entered the Recovery partition
  5. Used the Disk Utility to reformat my SSD
  6. Re-downloaded and re-installed Mountain Lion
  7. When asked if I wanted to use Migration Assistant, I opted out
  8. Manually reinstalled software, copied over files, etc.

I really think Migration Assitant had something to do with the lag. Either that, or some file or software I had caused the lag, and Migration Assitant simply brought the problem over to my new MacBook when it migrated all my files and settings. In any case, my MacBook Pro is now buttery smooth again, with none of the lagginess and graphics artifacts I had before. I'm happy!

Just for the record, here's all my MacBook Pro with Retina Display system information:

Mid 2012 model, 2.6 GHz Intel Core i7, 16 GB 1600 MHz DDR3 RAM

OS X version 10.8.2

I hope this helps anyone else with the same problem!

share|improve this answer
    
@bassplayer7, here are my findings, as promised. –  Titus Jan 28 '13 at 3:14
1  
Thanks, @Titus for letting me know, and thank you for coming back and taking care of the answer here to the question. I'm really glad it's working well for you. I am very happy that my computer has been running without those problems recently (not sure why). I'm hopeful that it continues indefinitely like that. –  bassplayer7 Jan 29 '13 at 0:46
    
@bassplayer7, yeah I'm really glad it worked! Here's to hoping both of our computers continue to run smoothly for many years to come. –  Titus Jan 30 '13 at 18:58
add comment

I will say backup and reinstall the system, or at least try clean the cache with applications like CleanMyMac or so.

I myself have experienced several problems with Retina MacBook Pro, so I can feel your pain.

Also, check if "Automatic Graphics Switching" is enabled under System Preferences - Energy Saver, and your resolution. HD 4000 cannot always handle higher resolution well.

share|improve this answer
    
Thanks for the quick answer! I already tried turning off Automatic graphics switching, but to no avail. I'm having the same problems. Again, with it turned off, I had no problems before the reboot (and my MacBook was driving two monitors). I'll probably try clearing my cache but I'll probably have to go with a system re-install (shudder), which I'm not looking forward to at all. –  Titus Jan 22 '13 at 17:43
    
@bassplayer7, I'm thinking that perhaps migration assistant could be messing something up? Perhaps if I install a clean system, and manually copy over all my files and reinstall the core group of programs that I use, the lag issue might disappear. Or maybe that is just wishful thinking on my part. IF this lag continues for any longer, however, I will have to try something! –  Titus Jan 22 '13 at 17:52
    
@Titus, let me know what happens if you do try. With this MBP I started over by re-installing the OS, then installing my main apps as well as copying my docs over. I didn't use Migration Assistant. If it's of interest my unibody MacBook is running 10.8.2 and I've never noticed a problem. Right this second, my MBP isn't having issues. But it hasn't been rebooted for a while. –  bassplayer7 Jan 22 '13 at 17:55
    
@bassplayer7, that's reassuring. Hopefully if I do this the "old school" way without Migration Assistant, this lag problem will just go away. I'll definitely let you know what happens if and when I try! –  Titus Jan 22 '13 at 17:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.