Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Birthday reminders are nice but not if they keep popping up each day for every contact that has a birthday filled in. I don't need a popup birthday reminder. Especially not for every contact that has a birthday. I don't want to edit all contacts that I do or don't want to be notified about. Seeing them in the calendar app will be enough for me.

For this reason I decided to just turn the birthday notifications off.

One way of doing this is to disable calendar notifications. But that sucks... now all calendar notifications are turned off...

An other option would be to disable calendar birthday events but somehow I still get the annoying reminders popping up each day. ( And with me some others according to some forms I've read ) And this also disables viewing them in the calendar app.

Then I read this:

Go to Settings/Mail, Contacts, Calendars then Calendars section: Default Alert Times/Birthdays. Switch it to None.

I will know by tomorrow if the 'trick' above worked but since I didn't find any q/a how to disable all birthday reminders easily I posted this here in hope to find a good answer that will fix this problem once and for all. Maybe I found an answer but if you could confirm it that would be great!

I'm using iOS 6.0 by the way and wonder how to disable birthday reminders in iOS and still view them in the calendar app?

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

Yes. This should work. As you are aware, when you (or the Facebook contact) inputs their birthday into the contact, iOS creates a new calendar called "Birthdays". On both iOS and OSX you have control over the notifications that you receive for each birthday that is on that calendar.

Like you said you could can go and turn of the notifications which should prevent notifications from actually appearing. Note, however that the birthdays should still show in Notification Center.

You can also disable the Birthday calendar on your iOS device altogether by opening the Calendar.app, tapping "Calendars" in the upper left corner, and scrolling down to and tapping on "Birthdays". You will see the check mark next to it disappear and the birthdays will no longer show in your calendar.

It, of course, would be easy to turn them back on temporarily in the future if you wanted to look up someone's birthday.

share|improve this answer
    
Actually I did turn them of in the Calendar app but they still show up. Maybe those are different alerts then the ones from the Calendar app? Now I can't test if the birthday's show up today on my iPad ( which is where I have turned them off ) because I left it at home. So I guess I have to wait until I get home again to accept an answer. –  FLY Jan 22 '13 at 8:24
    
@FLY, that sounds good. Apparently disabling the calendar just prevents the Birthday calendar from showing in the calendar. Changing the notifications, apparently are the only way to disable alerts. Let me know what you end up with. –  bassplayer7 Jan 22 '13 at 12:49
    
Yes switching default birthday alert to 'none' finally got rid of the alerts and I have them stil visible in my Calendar app. –  FLY Jan 23 '13 at 7:53
add comment

No, this doesn't work. Birthdays set to none in settings and Birthdays calendar unchecked and still getting those annoying facebook birthday reminders. Tried uninstalling facebook but that doesn't seem to work either. Facebook is like a persistent virus. Grr

share|improve this answer
    
I tested this and it does work for me. Maybe your reminders that are still active are from a different calendar? –  FLY May 5 '13 at 13:47
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.