Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

On my mac, I often try to go to Google.com and chrome gives me an error: "You attempted to reach www.google.com, but instead you actually reached a server identifying itself as www.apple.com. This may be caused by a misconfiguration on the server or by something more serious. An attacker on your network could be trying to get you to visit a fake (and potentially harmful) version of www.google.com. You cannot proceed because the website operator has requested heightened security for this domain."

Does anyone know how or why this is happening and how I can fix it? Generally if I restart my router the problem will go away temporarily, but it always comes back. It has been going on for several months now. The issue does not occur on my ThinkPad running Windows 7, my iPad 2, or my Nexus 7 tablet... only the Mac (OS X 10.8.2).

It seems like some sort of DNS poisoning, but I'm not sure why it would only happen on the Mac. I have tried the following, but to no avail:

  • pointing my router straight to Open DNS servers because I first thought it was my ISP's fault.
  • Using the "Keychain First Aid", but no issues were found.
  • Removing the "GTE CyberTrust Global Root" certificate and that created lots more problems, so I put it back.

I don't know enough to know what to try next or how to even go about diagnosing the issue.

Thanks for any help you can give.

share|improve this question

migrated from serverfault.com Jan 20 '13 at 22:29

This question came from our site for professional system and network administrators.

1 Answer 1

up vote 1 down vote accepted

Quit Safari. Then go to

System Preferences > Network

Click the padlock at the bottom, enter your Admin Id to unlock it. Then click 'Advanced...' and hit the 'DNS' tab. Remove the DNS address(es) with the +/- buttons at the bottom and replace with Google's DNS server

8.8.8.8

Click 'OK' and close System Preferences (command-Q).

Flush the DNS cache by opening Terminal.app and pasting this into the Terminal window:

sudo killall -HUP mDNSResponder

press 'return' on your keyboard, then enter your admin password, which will be invisible when you type it (so type carefully).

Restart Safari and test.

If the problem persists, open the /etc/hosts/ file by typing this in Terminal

sudo vi /etc/hosts

Look for any lines that mention either google.com or apple.com. Highlight them with the mouse and 'control-c' to copy. Past them as a response here. You can close the vi page by

first hitting the 'esc' key, then typing

:q 

(that's a colon and a 'q') then pressing 'return'. Quit Terminal.

share|improve this answer
    
Thanks for the detailed response! I'll give it a shot and see if it helps. –  Aaron Jan 22 '13 at 2:53
    
what if it is happening on chrome? it kept crashing first for months, giving me the sad face. Now, it is giving me an ssl error when i try to open google. In my safari it is working but not on my chrome. Any idea whats happening and how I can fix it –  Ane Mar 25 at 20:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.