Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'm having some strange issues on my MBP retina , suddenly it changes the audobalance, and the right speaker is being almost muted. Anyone knows what could be wrong here? I have OSX 10.8.2

share|improve this question
    
Could you verify that this i not caused by a broken jack cable? Try replacing the cable between your mac and your speakers. If it's broken and you move, it might lose the signal of one channel. –  Bart Arondson Jan 19 '13 at 21:47
    
Yeah, sure, I've already checked this. I've tried with earphones/speakers and mac own speakers, so when I check the balance on the system preferences > Audio and the balance bar shows it has been changed to left... oddly enough –  Manu Jan 20 '13 at 3:06
    
Do you use Skype or some other VOIP program? While in a call, these usually only play audio from one speaker to avoid interference with the microphone. Perhaps it's related to this. –  Szabolcs Jan 21 '13 at 0:07
    
Nope, I've checked that too, and I don't even have Skype installed on my machine... –  Manu Jan 22 '13 at 15:07
1  
I'm having the exact same issue with my MBP Mid-2010 "13. I noticed it a few days ago whenever I plugged in my speakers or headphones, and I thought it was a headphone issue until I decided to check the sound balance, and it was almost completely to the left. It's happened several times, and it seems as if it does it every time something is plugged into the headphone jack. It has to be some weird bug that Apple has yet to issue a patch for! –  user50776 Jun 7 '13 at 3:23

2 Answers 2

I've had this problem on multiple MacBooks (from my old Powerbook 15 from 2003 to prior to finding this question on my late 2011 MBP 13").

Apple has acknowledged it as a bug when pressing the volume buttons during heavy CPU usage way back in OS 10.2! The solution was to go back to preferences and set it back where you wanted.

share|improve this answer

I have this exact same issue. mid-'12 rMBP 15'' 256/2.6/16GB. OS X 10.8.2

First noticed the sound issue with my ear monitors (Shure headphones) plugged into the computer: the sound in my R earbud was like 80% diminished. But the earbuds worked fine on my iPhone 5, perfect output in each side. Last night, while watching a Netflix movie (occasionally plugging in my earphones into the rMBP), the laptop's R speaker suddenly lost all output. I freaked out, obviously, but quickly discovered that the balance bar had been shifted 90% to the L. Funny how that just changed itself mid-movie watching. Also, after I fixed the slider bar and the laptop's speakers started functioning as normal, when I plugged my earbuds back in, I had to go BACK into Audio preferences again to change the balance bar. Strangely enough, it was shifted L again, but more like 50%, not as extreme as it was for the laptop's speakers themselves.

Absolutely a software bug.

share|improve this answer

protected by Community Jun 7 '13 at 4:11

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.