Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Removed the old installation as explained here:

http://superuser.com/questions/129193/how-do-i-uninstall-mysql-on-mac-os-x-snow-leopard

Installed the package contained in the mysql 5.1.67 DMG downloaded from MySql.com Installed the preference pane item Installed the startup item [THIS FAILED]

MySql will not load, it's preference pane show the error message displayed below:

 The MySql database server installation was not found. 
 Please make sure the /usr/local/mysql/bin/mysqladmin file is present

I don't have much familiarity with unix commands so I'm not clear how to troubleshoot this further.

share|improve this question
    
Is /usr/local/mysql/bin/mysqladmin present? If so what does running it in Terminal show? –  Mark Jan 16 '13 at 13:12
    
UPDATE: I downloaded the 32-bit package (I had previously installed the 64 bit one) and it is installed. However, it will not run still. The error message in the preference pane now says: "Warning - The /Users/snp/emaildb/ directory is not owned by the 'mysql or _mysql user" –  snpower Jan 16 '13 at 15:24
    
That user directory is nothing to do with a plain mysql install- you must have some configuration or other program using it (and probably mysql) –  Mark Jan 16 '13 at 15:48
add comment

2 Answers

Try to uninstall the lates version completely and install the new one. According to your error log i think that you have another mysql server running on your machine. Try to find it out and uninstall it.

share|improve this answer
    
Ok so I did a complete uninstall again. Also uninstalled Logitech Media Server which is the only other thing on my system using sql. Rebooted. Did another install of the x64 bit version. Now I am back to getting the message that the MySql Database Server installation was not found, despite the fact that the installer reported a successful install. –  snpower Jan 16 '13 at 18:41
    
I tried another install, this one fails and reports these errors: (can't display them not enough characters available) –  snpower Jan 16 '13 at 18:45
    
try to make an update on OS. may be this can help you –  Festus Tamakloe Jan 16 '13 at 20:34
add comment

I got the same problem after installing mySql through homebrew brew install mysql.

After digging for a while, I realized that the problem was a missing symbolic link.

Since my mySql was installed in /usr/local/mysql-5.6.12-osx10.7-x86_64 and not in /usr/local/mysql as expected, all I did was create the symbolic link to map this missing path:

cd /usr/local
sudo ln -s mysql-5.6.12-osx10.7-x86_64 mysql

Now I can access /usr/local/mysql, and the mySql on System Preferences works fine.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.