Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

The "View in Mac App Store" button used to work in Chrome though, I think I turned it off by mistake though, I'm not sure. The button I'm referring to is under each app's icon and looks like so:

View in Mac App Store

There was a popup (2) which would show a bunch of stuff about opening the App Store app or not and I think there was a check box there that I clicked to not show the popup again though, for some reason when I did this the button itself stopped working and just does nothing instead of opening the app store (if that makes sense.)

Here is example of the popup I'm talking about (this is Firefox's version, however, which is a tad bit different.)

launch application

I've checked all the settings in Google Chrome itself (v24.0.1312.52) though, couldn't find anything for this and why I thought, I better ask here.

So, my questions are:

  • Where is the preference settings to open the App Store again, via the View in Mac App Store button; is it an OSX setting or a Chrome setting?
  • Is there a way to get the popups working again so I can change the preference if I set it wrong?
  • If this is in fact a Chrome specific question is this better suited SE site to ask this on?

Mac OSX v10.8.2 by the way.

Thanks!

share|improve this question
add comment

2 Answers

up vote 0 down vote accepted

I finally uninstalled Google Chrome, downloaded a new copy and reinstalled it again. The popups show again and all is working fine now.

I still have no idea where the settings are located as they aren't in their usual places as suggested by daGUY. Anyway, that fixed it for me even though, not a very good route I will admit.

share|improve this answer
add comment

In Chrome, go to Settings > Show advanced settings... > Privacy > Content settings... > Handlers > Manage handlers... and a window will pop up showing active and ignored protocol handlers. The macappstores protocol handler should be in the "ignored" list. Hover over it and click the X to delete it.


An alternative: try downloading and installing RCDefaultApp – it's a preference pane that lets you adjust protocol handlers, default apps for certain file types, etc. Once installed, go to System Preferences > Default Apps > Apps and you should see "App Store" in the list. Select that and make sure that all of the checkboxes in there (for macappstore, macappstores, etc.) are checked.

share|improve this answer
    
Thanks for the reply! Yeah, I checked every single setting in that area of Chrome including that one. It's not there! And why I thought it could be a setting in the OS instead (which wouldn't really make sense but, who knows.) –  Natetronn Jan 15 '13 at 21:50
    
Any other ideas by chance? –  Natetronn Jan 15 '13 at 23:36
    
They're all checked as you can see here –  Natetronn Jan 17 '13 at 5:52
    
Thanks for your help anyway daGUY! –  Natetronn Jan 17 '13 at 21:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.