Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I recently had a nasty problem with my iPhoto library that I corrected by rebuilding it. This restored missing/corrupted photos and fixed several other inconsistencies, so iPhoto is working properly again.

But now, iTunes is the one that's having problems. Whenever I connect my iPhone and visit the Photos pane, it tells me that my iPhoto library contains 0 photos (and, since I sync selectively, it says the same next to every item I've checked). It reported all the right counts before I rebuilt my iPhoto library.

Not only that, but whenever I sync for the first time after connecting, the photos will mysteriously disappear from my iPhone and I'm forced to resync them, even when I don't make any changes (not even outside the Photos pane). The photos then stay on my phone as usual, but once I connect and sync again, the same thing happens. I don't have a large photo library so it's only an extra couple of minutes of waiting, but it's still something I shouldn't have to put up with every single time I connect and sync my device.

I'm using iTunes 11.0.1 and iPhoto 9.4.2. My computer runs OS X 10.8.2, and my iPhone runs iOS 6.0.1. All are at their latest versions as of this writing.

What can I do to make iTunes read and sync my iPhoto library properly again?

share|improve this question
    
Can we assume all photos on all iOS devices that were placed there by iTunes can be wiped? You won't lose camera roll photos taken - just those that came from the computer. –  bmike Jan 15 '13 at 18:22
    
@bmike: Yes; my iPhone is the only device syncing with my iTunes and iPhoto libraries. –  BoltClock Jan 15 '13 at 18:45
add comment

2 Answers 2

Hopefully you have the run of the mill, the iPod Photo Cache is now stale issue which is easily remedied.

Since you are on Mountain Lion, this is just a folder in the "iPhoto Library" and you can right click on it, and show package contents. Just drag that folder to trash and then quit both iPhoto (and Aperture if you have it) as well as iTunes.

A re-launch of iTunes should see that the folder is missing and clear any sync tokens, and proceed to rebuild a list of pictures, albums and events. Usually, there isn't a second step needed as this folder is designed to be safe to delete at any time to save space on a drive and exists to speed up syncing.

As always, kicking off a backup when looking into deleting things is never a bad idea in case the corruption is deeper than expected or just a sign of a failing storage device.

share|improve this answer
    
That was one of the first things I tried, but it didn't have any effect. –  BoltClock Jan 16 '13 at 2:45
    
I wonder if a bad iPod Photo Cache is also responsible for my photos being displayed in the wrong order in my device's Photos app. –  BoltClock Jan 16 '13 at 2:54
    
It could - another good trick is to connect your iOS device to another iTunes and put on some dummy photos - force the database on iOS to be wiped. I've also connected to Xcode and watched for console messages once iTunes sync starts. The pictures get dumped, and then iOS builds a local database analogous to the iPhoto database on OS X. A bad filesystem or corruption there can also cause issues. Restoring the device and setting it up new usually fixes that if you don't have another computer. –  bmike Jan 16 '13 at 2:59
    
Xcode doesn't report anything amiss. I just tried syncing with iTunes on my PC, but I'm not sure if that helped any considering it's the same iTunes library (stored on a NAS), even though it's a different photo library since iPhoto obviously doesn't exist on my PC. That said, I got the "erase and sync" prompt that I usually do when removing the iPod Photo Cache, but when I return to iTunes on my Mac, it still says 0 photos in my iPhoto library there. I'm under the impression that it's more of an issue with my Mac than with my iOS device. –  BoltClock Jan 16 '13 at 6:25
    
Or maybe I'm just not keen on restoring and setting up as new since there's some data stuck in there that I can't back up outside of iTunes/iCloud (e.g. non-iCloud app data, text messages) :) –  BoltClock Jan 16 '13 at 6:28
show 1 more comment
up vote 1 down vote accepted

Ah, geez. Trust me to forget all about my own question until a year later (and then some).

I never found a way to fix my existing library, so I had planned to start from scratch by exporting all photos from my existing library, creating a new library, and importing and rebuilding everything by hand. Unfortunately, I never had a chance to do that either (yes, not in a whole year; don't ask).

Today, while preparing for an upgrade to my Mac, I decided to take a look at the problematic library again. Since a new version of iPhoto has been released coinciding with the release of OS X 10.9 Mavericks, I let it upgrade my library. So far, so good — the library opens and I can still see all my photos and metadata.

So I opened iTunes, connected my iPhone, and tried syncing the iPhoto library to it. After a few experiments... it looks like the syncing problem I described has vanished completely. Everything syncs properly now. iTunes reports all the correct numbers. And my iPhone doesn't get wiped on every subsequent connect-and-sync either.

I wish I could find out what exactly the upgrade process did to fix things so I could at least understand what the problem was and provide a much more useful answer. For now, I suppose all I can say is to wait and see if a library upgrade with an updated version of iPhoto works.

One thing's for sure, though: I'm not rebuilding my photo library from scratch anymore.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.