Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

When I enter my Messages.app settings for my iMessage account, I can see that I can receive iMessages on the two emails that I have entered. Is it possible to add my iPhone number to that list too?

Until now I have only found a way to add email accounts.

share|improve this question
2  
You've got two answers - one for if you are using Messages.app on OS X and the other if you are using it on iOS. –  bmike Jan 14 '13 at 16:29

3 Answers 3

up vote 2 down vote accepted

This is one of those things that should happen automatically - but doesn't always.

First step is to make sure your iPhone is on iOS 6. If it isn't, you won't get your phone number to show up (period).

After that, often the best and simplest way to get the phone number to show up is to disable iMessage and then re-enable it. In this case, you would open Settings in Messages.app on your Mountain Lion Mac, Select your iMessage account, and then tap the "Sign Out" button. When you sign back in your iPhone number should appear at the top of the list for "addresses" that you can text from.

This question/answer may also help in getting all your Messages apps in sync with each other.

share|improve this answer
    
On iOS it works, meaning that I already see the iPhone number on top of the list –  user1301428 Jan 14 '13 at 16:37
    
@user1301428, Did you disable/re-enable it on your Mac (I should have been more clear that the third paragraph was meant for Mac)? –  bassplayer7 Jan 14 '13 at 16:39
    
That worked, thank you :) –  user1301428 Jan 14 '13 at 16:40
    
@user1301428, Previously it had worked for me, so I'm glad it fixed it for you. Happy to help. –  bassplayer7 Jan 14 '13 at 16:42

I fussed around with this for a while too because my phone number wasn't showing up as an option, only my email. I signed out of messages on my macbookpro, quit the program. Went to Settings> Messages on my iPhone and realized I didn't have imessages turned on. I turned it on. I also had updated my apple ID a while ago to my gmail account, but for some reason, messages on my macbook pro had to go back to email@me.com for my phone number to show.

share|improve this answer

The only way to link a phone number to an iMessage / iCloud / Apple ID is to sign in to iMessage on an iPhone with service to that number. That iPhone also needs real SMS messages to be sent one time immediately after activation to verify the SMS is delivered to the same phone as the iMessage account.

From then on, that phone is associated with that Apple ID unless you re-link that phone number to a second Apple ID at a later time.

Apple has a nice article on how to manage iOS messages and phone numbers / SMS online:

share|improve this answer
    
I have already done this, but unfortunately on my Mac I still see only the email addresses. Maybe it will just take some time for everything to update –  user1301428 Jan 14 '13 at 16:38
    
No - it's instant. If your phone completes the registration, and the SMS message from Apple gets delivered, you should see your phone number immediately on the device and also get an email / notification on all other devices that "phone number xxx-yyy-zzzz" has just been added to Apple ID "you@wherever.com" –  bmike Jan 14 '13 at 17:08
    
I didn't receive any automatic notification. However, signing out and immediately back in on the Mac solved the problem. –  user1301428 Jan 14 '13 at 17:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.