Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

We recently bought an iPhone 3GS for my stepson. He has my old iMac G5, running OS X 10.4.11 (Tiger), and iTunes 9.2.1.

When we connect the iPhone to this computer, we get an error window saying "The iPhone cannot be used because it requires iTunes version 10.1 or later. Go to to download the latest version of iTunes."

However, the iTunes download page says that iTunes 10.1.2 requires OS X 10.5 or later, and indeed, trying to download and install that version results in an error window saying "This package type requires Mac OS X 10.5."

So, is there any way to get a version of iTunes that supports the iPhone 3GS and runs on OS X 10.4.x?

If not, would upgrading the iMac to Leopard solve the problem?

(This is all a bit surprising, because iTunes 9.2.1 worked fine with an older iPhone and with an iPod Touch. It's hard for me to imagine what new magic in 10.5 is required to support syncing with a slightly newer model of iPhone.)

share|improve this question
up vote 2 down vote accepted

Yes, upgrading the Mac to Leopard will work.

Each new iDevice has certain identifiers (model number, etc.). When Apple releases a new one, the old version of iTunes would need an update to recognize it. (Sometimes this even happens with new device OS/firmware versions.) They bundle these updates with feature and bugfix updates, so you're stuck with a new version.

share|improve this answer
Well, this is annoying, but it forced me to find time to upgrade that old iMac to Leopard. All is good now. Thanks! – Kristopher Johnson Feb 10 '11 at 19:02

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.