Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I want know how can I apply a software to open all my same document, for example I want to open all my PDF document with Skim but when I right click on it> open with > other and choose my desired application and check the "Always Open With" it just do for that specific file.(mean always open A.pdf with skim if I want to open B.pdf still open with "preview").

How can I force OS X to open all pdf type with Skim.

alt text

share|improve this question
Out of curiosity, what OS version are you using? 10.6? (this isn't relevant to the question, I'm just a curious dude ;)) – Matt Jun 9 '14 at 23:49
this question is too old that time I had snow leopard – Am1rr3zA Jun 10 '14 at 6:45
up vote 28 down vote accepted

From the Finder, select a PDF file, open the Info panel (FileGet Info or I), select your preferred application and then click Change All…

change all

share|improve this answer
The UI related to changing default documents is misleading. I'm reading this question because I'm seeing this in 10.10.4 -- set TextWrangler as the default (Always Open With) for XML via the Open With... dialog, yet it still wants to open with Xcode. Your fix fixed it. Apple needs to fix this behavior. – jcollum Aug 24 '15 at 14:54
now is 2016 and this answer is still useful, thanks!! – hihell Apr 9 at 18:03

If you want to mess with all filetypes and "who opens what", there is a freeware System Preference Pane called RCDefaultApp that works in Snow Leopard, Leopard, Tiger and Panther.

You can change pretty much any type of resource, for example you can tell that “Acorn” opens png by default or that the default app for the extension “jpg” should be, etc.

It also handles MIME types, URLs, and Media.

share|improve this answer
+1 for suggesting nice software – Am1rr3zA Sep 11 '10 at 11:32

I had this problem today as well (Mavericks) but the solutions here didn't work. This is due to a corrupt services cache. I ran the following command in terminal and things started working again

/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -kill -r -domain local -domain system -domain user

So if anyone the answers don't work for you, run this command and then it should be fine after that

share|improve this answer

Another option is to right click the file in Finder and then change "Open With" to "Always Open With" by holding down the option (⌥) key.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.