Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have a 2011 generation Macbook Pro, upgrade to 16gb RAM and a 128gb SSD drive - running Mountain Lion and iTunes 11.

During playback (approximately 20 times per song) it stutters, stops playing for a few seconds, and then resumes from where it left off. It seems to co-incide with my using the keyboard or performing any file operations - and at the same time the file operations freeze up. The following screenshot was taken about 3 seconds after a skip and doesn't show any signficant CPU activity:

enter image description here

However, if I close iTunes, I get no problems with file operations, or any other app on my machine - leading me to believe that iTunes is causing the problem. Has anyone else run into anything similar, or have any advice on stopping iTunes being such a resource hog?

Note: Other apps (for instance VLC) have no problem with playback under the same conditions.

share|improve this question
    
Can you run top -o cpu (in Terminal) or Activity Monitor during playback to see what else is consuming CPU time? –  patrix Jan 12 '13 at 13:16
    
Screenshot of both: img.iamp.me/eI6m (That was three seconds after a skip) –  George Pearce Jan 12 '13 at 13:19
    
Side note- when it happens, the read speed on the drive drops to zero for several seconds, often the write speed is zero too. –  George Pearce Jan 12 '13 at 13:20
    
CPU looks ok, I would suspect the drive anyway now. The speed drop points in the same direction. –  patrix Jan 12 '13 at 13:22
    
Does that imply a dud drive? I've been thinking about swapping back to the 'moving part' drive anyhow. –  George Pearce Jan 12 '13 at 13:29

5 Answers 5

up vote 1 down vote accepted

Buried deep in the comments are these answers to solve the riddle of the stuttering iTunes playback on Mountain Lion:

I've just remembered that I have FileVault enabled, and as the crashes / skips happen when the computer is performing file ops, I think turning FV off might help - decryping my hard drive now... – George Pearce Jan 12 at 14:34

Update: Turning off filevault and decrypting my hard drive appears to have entirely solved the problem. – George Pearce Jan 12 at 19:20

share|improve this answer

I have the same issue on Windows since upgrading to version 11. My guess is that the application does not buffer as well as it used to - so a load on the system causes playback stutter.

A workaround that seems to work is to run iTunes as a high priority process. This can be achieved on Windows 8 via the task manager ("Details" tab) or by changing the iTunes shortcut to be:

cmd.exe /c start ""/High "C:\Program Files (x86)\iTunes\iTunes.exe"

share|improve this answer
    
As the asker here posted OS X screen shot (and mentioned Mountain Lion), a windows tuning parameter might not have the intended effect. –  bmike Sep 20 '13 at 20:12

Use an external audio player like Amarra to take control of the buffer and playback and see if this helps. Amarra has settings for how much of a track to buffer before playing

share|improve this answer

You're sure these are not songs that are coming from the cloud?

share|improve this answer
1  
This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. –  bassplayer7 Feb 1 '13 at 14:33
    
It's terse, but delays to stream under iTunes Match are my #1 cause of unsmooth playback. Just about all machines have iTunes playback at such a high priority (and are fast enough to pause other workloads to prevent the audio play buffer from emptying) that it's almost always a media error and not a performance issue on the Mac IMO. –  bmike Feb 1 '13 at 14:38
    
This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post. –  Mark Feb 1 '13 at 20:44

Turn OFF "Put hard disks to sleep when possible" in Energy Saver Settings!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.