Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I've just upgraded from 10.5 to 10.6.3 and all seemed to go OK, except that now no keyboard shortcuts work in any application. The keyboard viewer shows me that the command keys are working fine, and some global shortcuts work fine when I've configured them to (e.g. command-space to produce the Spotlight search box).

But all applications (e.g. Finder, Safari, Chrome, Terminal) ignore any shortcuts I type at them, even if I use the keyboard viewer to type them.

Oh yes, one other strange anomaly: in Chrome, if I type command-C, it brings up the Developer Tools window if the selection is in the main body rather than the URL box.

Another anomaly I've just found: in the iTunes search box, the backspace key and the arrow keys don't have their usual function - they produce blanks. If I copy that text, it seems the key codes are going through uninterpreted (here I typed 'a' followed by backspace, left arrow, right arrow, up arrow, down arrow):

% pbpaste | od -c
0000000    a  \b 034 035 036 037                                        
0000006
%

What on earth is going on, and how can I stop it?!

share|improve this question
    
Try restoring defaults in SysPref>keyboard shortcuts tab. –  Randy6T9 Feb 5 '11 at 1:32
    
no change when i did that. –  rogpeppe Feb 5 '11 at 20:36
    
Hi - I can't answer the question but after a recent update My Mac started doing the same thing. I have Open Office, Chrome, Firefox and XCode on the machine. I upgraded Xcode in the last 3 weeks and I did a full update last week. Being an old PC guy I am used to computers breaking, just not my Powerbook. –  user6906 Jun 1 '11 at 19:11
    
I am at a workshop in Korea. One of the participants has the same problem. None of the Command key shortcuts work. I have tried the usual remedies, e.g., reset keyboard to defaults, switched keyboards, safe boot. Last night I zapped the PRAM three times but that didn't work either. Today I plan to follow some of the suggestions offered above but hope someone has found a solution. –  user14225 Nov 28 '11 at 1:11

6 Answers 6

This may not help directly but have you tried creating another account on the system to see if you experience the same issues? If a new account does work then I am willing to bet a plist file in ~/Library/Preferences/ got messed up or not upgraded to the new 10.6 format. I recall a similar key mapping issue when I went from 10.4 to 10.5.

share|improve this answer
    
That's an excellent suggestion. It does indeed work when logged in as Guest. Problem still not solved, but it seems possible now! –  rogpeppe Feb 5 '11 at 9:57
    
Only problem is there are 67 .plist files that have changed since I reinstalled holding 2.6MB of data... What's the likelyhood that doing mv ~/Library/Preferences ~/Library/Preferences.old will break things even worse? –  rogpeppe Feb 5 '11 at 10:11
    
I just tried a little experiment. I created a new user account, and copied (with ditto) the original ~/Library/Preferences to the new account Library/Preferences. Then I logged in to the new account. Command keys still work in the new account. So I think that eliminates ~/Library/Preferences as a candidate. –  rogpeppe Feb 7 '11 at 9:09
    
Another experiment: I logged out and used another account to move ~/Library to ~/Library.old. I logged back in again and the problem still occurred. So I don't think the problem is with anything in ~/Library. Where else does Mac OS keep per-user data? –  rogpeppe Feb 7 '11 at 10:17

Ok I had the same problem and fixed it. I went through all of the Keyboard settings for the Command keys and applications and hit "Restore Defaults".

share|improve this answer

My cmd + alt + ctrl keys did't working.

My solution: Go to System Preferences -> Universal Access -> Keyboard -> Set key repeat ... and assign the default input for any key because the were turned off!

I think that this info can be really helpful for someone ;)

share|improve this answer

Try a repair permissions in disk utility. Sometimes permissions problems after an upgrade can screw up normal functioning of system/application files

share|improve this answer
    
i tried this. it said it had some permissions to repair, so i repaired them, rebooted and... no change. oh well. –  rogpeppe Feb 7 '11 at 7:49

You could try "jiggling" your keyboard layout by temporarily selecting another layout in SysPrefs>Language & Text>Input Sources. I've no idea if that might help, but it's something I'd try.

share|improve this answer
    
no joy with that, sadly. –  rogpeppe Feb 6 '11 at 11:58
up vote 0 down vote accepted

I have now solved this problem by deleting my user account and creating another account with the same name (but a different UID) using the original home directory.

Some folks at Apple support were baffled by the problem and said they hadn't seen anything like it. If anyone knows where the problem was lurking, I'd still love to know.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.