Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I've just changed the screen on an iPhone 4S with iOS 6.0.1. Everything went fine until I noticed that the phone was not detecting any SIM card. It doesn't matter what you do with the SIM bay, the phone is always showing "No Sim" at the top.

I've tried to reboot several times with and without the SIM card inserted, different SIM cards, all that stuff with no luck.

After a few hours and with no exits, I've tried to restore the phone but still the same problem. And now, as the SIM is not detected, I can’t activate nor access the phone at all.

A friend of mine just told me today that he had a similar story but he fixed the problem setting the correct date and time manually. I can't try that now because Apple decided to make this stupid activation process but, as he said, is a common problem with iOS 6.x.x and iPhone 4S.

Now, do you have any ideas on how can I activate the phone or set the date and time to the correct one just to try if it helps?

share|improve this question
    
btw.. hacktivation is not an option because 4s is not supported yet with ios 6.0.1 –  Luis Jan 8 '13 at 15:26
    
is your phone locked? if it is not locked, you can try to activate via wifi. –  neo Jan 8 '13 at 15:29
    
That's not an option because it asks for a sim card all the time.. the phone is not locked. –  Luis Jan 22 '13 at 10:57
    
I ended up bringing it to an Apple Store and get a new one for 199€. Thanks for your help. This post can be safely closed. –  Luis Feb 9 '13 at 16:28
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.