Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Ok, in the /Users/Shared/ folder I have my DropBox folder.

I have read/write permissions set for me and my wife (shared computer). However, if she creates a folder/file in the DropBox folder, I can see it but I have to type in my password to delete or edit it. And she has to do the same if I create something.

How can I make it so that if she creates a file/folder in the DropBox folder, we both automatically are the owners? It doesn't seem to me that the Shared folder does a very good job of, well, SHARING. Even though I have set both of our accounts as read/write on Shared and all contents.

This is driving me insane.

Thanks.

share|improve this question
add comment

3 Answers

OS X has two main levels of file-level credential control:

  • users
  • groups

Right now, it sounds like your wife has "ownership" of the dropbox folder, much to your frustration.

To rectify this, you will want to use the Users and Groups preference panel to either

  1. (if everyone who uses the computer can have access to the dropbox folder) proceed to the last step, using the everyone access control group.
  2. (if you have multiple people using the computer, but only you and your wife can have access to the dropbox folder) create a new group, perhaps called Dropbox, and add you and your wife's accounts to this group.
  3. (if both you and your wife understand the power of being Administrator, and both you and your wife would be the only Administrator on this computer) add both your and your wife's account to the Administers group.
  4. Set the permissions on the Dropbox folder to give full control to this group from 1 through 3.
    • In Finder, select the Dropbox folder and press CMD-I (Get Info).
    • You might need to unlock the panel if you see the locked padlock in the lower right corner. Click on the Lockard provide an Administrator password.
    • In the Permissions section (towards the bottom)
      • if you see the group already in the list, set the permission to Read and Write
      • if you don't see your group in the list, click the + button on the groups side, select and add your group and set it to Read and Write
    • Be sure to set the drop list at the very bottom to Apply to enclosed items BEFORE you close the Get Info tab.

Choose wisely, but this process will eliminate your having to authenticate every time you want to use Dropbox.

share|improve this answer
    
Thanks, @TomUnderhill, for adding some alternative ways to go about this using the GUI. –  Daniel Zhang Jan 6 '13 at 20:07
add comment

You can solve this problem using group permissions. What you want is to have a file mode creation mask set such that group read, write, and execute permissions are automatically set for each file when a file is created. This can be accomplished using the umask command inside your startup script such as ~/.bash_profile. To set rw permissions on all files, rwx on all directories, that you both create, use

# Set the umask such that user and group can read, write, and execute.
umask u=rwx,g=rwx,o=

Furthermore, you may want to set everything in the Dropbox to have at a minimum rw group permissions for files and rwx permissions for folders. You can accomplish this using

chmod -R g+r,g+w /Users/Shared

for files and use

chmod -R g+x /Users/Shared/FOLDER

for folders. You can view the existing permissions in the terminal using

ls -l /Users/Shared

where the rwx permissions are arranged in order of owner, group, and other.

share|improve this answer
    
Great answer for a Terminal-savvy user, @Daniel Zhang. I've given the same procedure using the graphical interface. –  TomUnderhill Jan 6 '13 at 19:43
add comment

I think that batter solution for that will be installing on other computer another instance of dropbox app? You can use your same credentials or other (with sharing enabled within dropbox site).

It will enable other computer to access files when your computer will be sleep/off.

share|improve this answer
    
Regardless of where the file resides, *OWNERSHIP, not access, is the issue at hand. –  TomUnderhill Jan 6 '13 at 19:41
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.