Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'm in a little over my head. MacBook Pro, OSX 10.8.2: I just created an encrypted image (128 bits read/write), that Image Disk mounts fine...I can see the number of files and folders, but none of the files are visible to me. I can see the subfolders, but none of the files at all. Seems like using encryption for the partition was NOT good.

I've tried the Disk Utility to Convert the .PNG...I've tried to Restore the Image (folder) from the Partition, but I keep getting duplicates of the same Invisible Files. I'm guessing I also can't delete these either.

The files are there, can be seen via the Terminal, but they are invisible. Maybe because of attribute properties on the prefix of each file? Each file starts with a "-rw-r--r--@".

Is chmod possible to adjust the attributes/? Can anyone help with the right line entries.

Is there anything else I can do?

Thanks in advance for any help.

kd

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

The 'Image from Folder' will use the existing ownership/permissions of the folder and files.

First off, is the disk image a read/write image? Are you able to add new files to it? If not, the instructions below won't work if it is read-only.

The permissions you've listed, "-rw-r--r--@", mean that the file is read and writable by the owner and readable by everyone else. The @ at the end means there are extended attributes to the file, which might include some kind of invisibility option. You would have to get a directory listing with -@ to show the attribute keys. For example, here is a listing showing an image that I manually set to be hidden.

$ ls -l@
-rw-r--r--@ 1 insom  staff  - 64832 Dec  6 18:56 FunnyImage.png
    com.apple.FinderInfo       32

If all your files also have a com.apple.FinderInfo attribute, use Terminal to change into the directory of the files and run the following command to unhide the files.

chflags nohidden *

Now, if your dir listing doesn't show the com.apple.FinderInfo attribute then they are not being hidden using this method but something else is going on.

Have you tried rebooting? What about copying the disk image to a different computer and mounting it?

share|improve this answer
    
Yes, the disk image is read/write. I just added a file and it is visible. –  user37993 Jan 6 '13 at 4:59
    
Let me also say that the folder was named "misc.noindex" before I Imaged it. –  user37993 Jan 6 '13 at 5:00
    
<<Sorry...I keep hitting 'return' and making new comments:>> Here's a copy/paste from the Terminal:-rw-r--r--@ 1 kdouglas staff 2503588 Jan 1 11:00 IMG_1542.JPG com.apple.FinderInfo 32 I'll try the chflags command. Thanks –  user37993 Jan 6 '13 at 5:09
    
chflags nohidden * Was the fix!! Thank you sir!!! –  user37993 Jan 6 '13 at 5:23
    
Glad to hear it was an easy fix. Please don't forget to approve this as the best answer. No idea why it happened in the first place. I tried creating an image named the same 'misc.noindex' just in case it was the noindex part that would set some strange parameter but it worked perfectly. –  InsomniacSoftware Jan 6 '13 at 5:29
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.