Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Tweeting through Notification Centre share buttons plays "Tweet sent" bird whistle through my iMac's internal speakers. This only happened when I re-enabled the option to select internal speakers themselves by unplugging the speakers, installing more RAM, restarting the computer and plugging the speakers back in.

Before this, Mountain Lion played all sounds through my headphones; the selected audio output device in System Preferences.app > Sound. Now all sounds are being played through the output device as they always did—except for the "Tweet sent" sound—definitely not what I want.

How can I get it so the "Tweet sent" sound plays through my headphones again?

This also applies to other system/alert sounds it seems, such as the set alert sound, emptying the trash.

share|improve this question

1 Answer 1

up vote 3 down vote accepted
  • Open System Preferences
  • Go to Sound -> Sound Effects Tab
  • Select "Play sound effects through selected sound output device"
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.