Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I would like to stop messages on my Mac from loading up all the messages I have on my iPhone when I plug it in.

Scenario: receive 10 iMessages on my iPhone during the day. I then delete them. So messages inbox on iPhone is empty.

I then plug phone into MacBook Air at the end of the day. When I open messages on the Air, and all messages load up, even though the ones that were deleted on my iPhone.

How do I stop this from happening?

I would like my iPhone messages to stay on my iPhone only, and my computer messages to stay on my Mac only.

share|improve this question
    
What version of OSX are you running? –  bassplayer7 Jan 2 '13 at 14:39

1 Answer 1

It sounds like you simply have iMessage enabled on your Mac (which doesn't have anything to do with plugging your phone in, since your messages are synced through iCloud).

Anyway, just open up Messages (iChat), go to Preferences > Accounts, select your iMessage account in the list on the left and then unchecked the "enable this account" checkbox.

share|improve this answer
    
Thanks, I bought my MacAir last week and so things have been a little different since the upgrade from my old one. I'm not very MacLiterate, so how am I able to use iChat while at my computer to message friends to either their phone/computer? –  sara Jan 3 '13 at 0:13
    
@sara: if you want to message someone's phone from your computer, that's what iMessage is for, so it'll need to be enabled. –  daGUY Jan 3 '13 at 13:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.