Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Bought an iPod Touch for my son which I then discovered is a 2nd gen which doesn't support lots of apps and games. Currently I either have to try downloading a game to see if it fails or read the blurb for each one, which is a complete pain in the ass. Is there any way to sort or filter iTunes so that the only results I see are the ones which will actually work on 4.2.1?

share|improve this question
1  
Doesn't iTunes on the device filter things to only show apps you can install? Also, iTunes on the computer should error out and not install apps that will not work if you automatically sync all apps and then delete the ones you don't need. –  bmike Dec 31 '12 at 4:46

1 Answer 1

First I would try upgrading the iOS if possible. From limited research it seems that some games are requiring 4.3. I don't know if your iPod will work with 4.3.

Here is a limited list of compatible games I found http://forums.toucharcade.com/showthread.php?t=153098

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.