Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I tried to move an app on my jailbroken iPod touch 4th generation to the system partition to free up space. I moved the app from /var/mobile/Applications to / and then created a symlink in /var/mobile/Applications which points to the actual .app in the / folder. After i did this i went and opened the app i moved and it worked fine. However, i tried to open the settings app and it crashed immediately. I rebooted to see if that would fix it, but now all of my system apps are missing from the springboard and openssh is not working. Can someone please tell me why it did this and how to fix it.

share|improve this question
    
Did you try to remove the symlink and move the app back to /var/mobile/Applications? –  patrix Dec 30 '12 at 20:27
    
well i deleted the symlink and the app –  Evan Dec 30 '12 at 20:30
    
@patrix i mean the system apps are still missing and openssh is not working so i cant check the permissions on them from my computer and ifile is a system app so i cant use that either –  Evan Dec 30 '12 at 21:11
    
Not to be rude or anything, but I think this is hilarious. I've done plenty of things like this, though, so I feel your pain, and I'm not laughing at you; I'm laughing at what happened. You should try using a desktop iPhone file browser to fix the problem. I use iFunbox myself, but any of them will do. I'm trying to think what would cause this, and I'm thinking the fact that mobile is accessing files on the /System partition is making iOS freak out. As to why it would freak out is a different issue all together. –  Andrew Larsson Jan 10 '13 at 16:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.