Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have a 2012 MacBook Pro with Retina display (currently running Mountain Lion v10.8.2).

Every time I wake it up from sleep (open the lid), it doesn't seem to automatically re-connect to the Wi-Fi network. If I manually click on the connect button, it works fine. I'm fairly sure this used to work.

How can I fix this?

share|improve this question
add comment

1 Answer

up vote 5 down vote accepted

It should automatically reconnect but it might take a couple of seconds, more depending on the speed of your wireless router. How long are you waiting?

It will automatically join a network if you have configured it to remember networks you have previously joined. You can check this in the System Preferences>Network page. Click on the WiFi entry then on the Advanced button. In the Wi-Fi tab is a list of Preferred Networks. Make sure your network is listed, with the correct security mode. If it is listed but not at the top, perhaps the laptop is trying other networks first. Move your preferred network to the top of the list.

If that still doesn't work, try deleting it from the list, click OK, click Apply. Then turn off the Wifi by clicking the "Turn WiFi off" button above. Then turn it back on and choose your network, making sure that it is set to remember. Save/Apply and close the System Preferences and try sleeping again.

share|improve this answer
    
Thanks; I thought I'd tried all of the above but when I went to remove the network I realised that the one that was stored had no security settings which was why it didn't automatically connect. Removing that one and re-adding is solved the issue... –  Jon Cage Jan 1 '13 at 13:34
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.