Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Seems the most common relationship to this error is using Windows on a separate partition. Here is my problem. I have a 1 TB external disk that was used half for Time Machine and half for general storage, partition called Mac Swap. In order to make a more elegant back up, I replaced my Time Machine with a full 2 TB external disk. This allowed me to delete the old half (just rendered obsolete) and extend the Mac Swap half to a full 1 TB. But that is where I got stuck. I can't extend the partition, Mac Swap.

Command+S only works on the boot disk, right? /sbin /fsck -fy won't solve this. But on the bright side, it seemed to repair a few minor errors on my boot disk.

Please help.

share|improve this question

I found my silly error. The solution: in Disk Utility, I chose specifically the partition that wasn't able to increase in size, then I ran the verification. It turned up problems so I ran the repair command. Then I was able to increase the size of the partition. Mt external hard disk, Mac Swap, is now only one partition.

To be clear about my error, in case you're reading this for help. In Disk Utility, there is always both an icon for the disk as a whole and below it immediately there will be all of its partitions. If you run the verification on the hard disk as a whole, then it may not catch what's wrong on your partition.

share|improve this answer
To extend this: running a verify/repair on an entire disk checks different things than running verify/repair on a volume within the disk (even if the disk is just a single volume). For a full checkup, you want to run the verify/repair process on each of the items that appears in Disk Utility's sidebar. – Gordon Davisson Dec 29 '12 at 18:17

This error was resolved for me by doing this on the original mac I formatted the drive with. I have two macbooks and I was using my second one to re-partition which caused the error. Going back to the macbook I formatted it on, let me re-partition without issue. I don't know any other fix to this or if the other methods work.

share|improve this answer

My external disk was originally in NTFS format with only one partition. The Disk Utility shows two levels for this disk. It always failed to erase this disk when I directly chose the sub-level with disk name on it. As inspired by seano23's answer, I chose the top-level and selected mac map and extended journal format to erase with. The process is successfully done.

Hope my experience could be helpful.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.