Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I don't have a single clue how my Mac OS comes to be like this..

Whenever I'm prompted to enter my password for admin rights to make changes to the system, my Mac OS seems to have a hard time finding the correct characters to represent the Roman alphabets it wants to display. Here are some screenshots regarding what it shows:

enter image description here

enter image description here

I suppose there is some bug (it is a Mac OS X version 10.7.5) or maybe I've accidentally deleted some system files required for the encoding..

This isn't really a big problem (since everything else works well), but as time goes by I feel the need to fix it.

I would appreciate if someone can provide me a solution.

share|improve this question
Does it also affect the force quit window? Have your tried resetting the font cache (sudo atsutil databases -remove; atsutil server -shutdown)? – user495470 Dec 28 '12 at 12:52
@LauriRanta Yes, the force quit window is affected too. Thanks for teaching me the atsutil command-lines! After resetting the font cache, the system is able to figure out that there is a conflict between some font files and after moving them to trash the encoding works properly. – user36864 Dec 28 '12 at 14:13
@LauriRanta The problem is now solved :D Why don't you type your solution down as an answer and let me accept it? – user36864 Dec 28 '12 at 14:17
Just in case anyone else had the same: the issue arose for me when I tried installing Apple's San Francisco font in Yosemite. If you open Fontbook and disable the font (select and hit the checkmark button at the top), it fixes it. – AdrianCooney Dec 7 '15 at 17:55
up vote 1 down vote accepted

So apparently it was solved by removing the fontd databases and deleting the files of conflicting fonts. (I guess the conflicting fonts were shown in Font Book?)

sudo atsutil databases -remove; atsutil server -shutdown

The password dialogs and force quit window are shown by processes owned by the root, so -removeUser might not work. launchd starts a new fontd process automatically, so atsutil server -ping is not needed.

share|improve this answer

using about your own name and scramble with it

share|improve this answer
Perhaps someone can edit this into a more clear solution? – bmike Jun 17 '13 at 12:07

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.