Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Setting a filetype to always open with a specific application works only until I restart my computer. Macbook Pro Retina under OSX version 10.7.5.

Why?

share|improve this question
    
Have you tried rebuilding the Launch Services database? –  Lauri Ranta Dec 28 '12 at 12:53
    
@LauriRanta I'm getting > Frameworks/LaunchServices.framework/Support/lsregister \ > -kill -r -domain local -domain system -domain user -bash: /System/Library/Frameworks/ApplicationServices.framework/Frameworks/LaunchServic‌​es.framework/Support/lsregister: No such file or directory –  Dokkat Dec 28 '12 at 13:25
    
I accidentally linked an older article. Try the command here. –  Lauri Ranta Dec 28 '12 at 15:39
    
@LauriRanta It worked perfectly, thank you. –  Dokkat Jan 8 '13 at 11:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.