Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Every time I enable my Gmail account (Google Talk) in Messages, I get a message asking if I wish to continue with an unsecure Jabber login. This message reappears every time I open Messages on OS X Mountain Lion, and every few minutes if I keep the account on.

error message

I could just click "Continue" each time, or better yet, disable the warning in Settings, but I would rather connect with a secure login.

Is there a way to get Messages to connect securely to Google Talk?

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

econ-mit posted the answer here: https://discussions.apple.com/thread/3745358?start=0&tstart=0

Messages > Preferences... > Accounts (select Gmail Google Talk) > Server Settings > uncheck "Automatically find server and port" > click SSL

When I did that, the Server field changed from gmail.com to talk.google.com and it immediately worked.

share|improve this answer
    
When I added the account in just now, it worked from the beginning so perhaps Google has fixed the "bug". Thanks for the tip. –  bassplayer7 Jul 8 '13 at 16:09
add comment

You can't connect securely to Google Talk.

As you mentioned, it is possible to turn off the warning. In Messages, open Preferences, select the Accounts tab, then select your Google Talk account on the left. Go to the Server Settings tab on the right, then deselect "Warn before sending password insecurely". This checkbox will be disabled if the account is connected, so you'll have to disconnect to make that change.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.