Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

On my new iMac /w a 1TB Fusion Drive, I tried to install Windows 8 (still technically unsupported) using the following method:

http://arstechnica.com/information-technology/2012/11/no-support-no-problem-inst alling-windows-8-on-a-mac-with-boot-camp/

Everything was proceeding just fine; I had Boot Camp copy all of the Windows 8 files (a legitimate, store-bought copy) to a bootable USB drive - a feature only available on new Macs running Boot Camp Assistant that don't come with an internal optical drive - and create a 102 Gb partition on the Fusion Drive. It then rebooted and was proceeding through the Windows 8 setup wizard as should be expected, but it couldn't modify any of the partitions on the Fusion Drive and wouldn't proceed. I accepted defeat and decided I would just wait until Windows 8 is officially supported before trying again.

Now, every time I turn the computer on, I get an error message saying "No Bootable Device...", unless I hold down the Option key and manually select "Macintosh HD" (the only boot device listed). I already removed the primary Windows 8 partition, but it hasn't fixed the issue.

I'm thinking that it's one of the 'hidden' partitions causing it to behave like this, or something wrong with the EFI bootloader, but I don't know how to proceed. Any thoughts on this?

share|improve this question

3 Answers 3

I had a similar issue installing Windows 8 x64 on a 2013 Macbook Pro Retina running Mac OS 10.8.3 (which does support Windows 8) and the problem turned out to be an issue between the 32GB USB 3.0 installer drive I was using and Bootcamp Assistant/Mac OS. The USB drive was not defective.

I went through the Boot Camp Assistant process three times using a Microcenter branded 32GB USB 3.0 thumb-drive. When the system would reboot to start the Windows 8 installation process I would get a "No Bootable Device" error. After reading a suggesstion from another site I changed USB drives and used a Microcenter branded 16GB USB 2.0 thumb-drive and the Windows 8 installer USB was found and installation proceeded successfully.

share|improve this answer

Go to system preferences then startup disk. Then select Mac OS X and hit restart.

share|improve this answer

Ok, so the first thing I should have tried resolved the issue: I just needed to repair the fusion drive in Disk Utility. Didn't even need to do it from a recovery partition - it updated all of the boot preferences perfectly.

...and now just to play the waiting game until Boot Camp Assistant finally functions properly with Windows 8. :P

share|improve this answer
    
Bootcamp does not support Windows 8 Apple note –  Mark Mar 29 '13 at 18:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.